Need help? Check out our Support site, then


Support Add New »

Topic Post Count Last Poster Freshness
I can make links, but they do not work 1 unlimitedconnectivity 2 years
Blog appearance - widgets, posts 6 askfundraiser 2 years
Layout Appearance Bug? 2 justpi 2 years
Wrong date and hour 3 julienwatine 2 years
Blog Birthday 1 tomte71199 2 years
Security message when I try to upload a link 3 tomwisk 2 years
Excited! Got my two first likes today! Question: how does one get found here? 1 taniadamha 2 years
My country does not seem to be valid, why? 10 musiclifeng 2 years
Urgent please - cancel domain mapping 2 bryanvillarin 2 years
Help! All my photos are lost! 13 timethief 2 years
How do I contact support when I DO have an upgrade package? 2 bryanvillarin 2 years
change URL 4 bryanvillarin 2 years
Deleteing Blogs/Account 2 timethief 2 years
i cannot post pictures on my new post 1 giovannijames 2 years
Why can't I map my domain to a different domain? 6 bryanvillarin 2 years
BLOG POST REMOVED 4 timethief 2 years
Images in posts are squished on the homepage 1 maxsblogosaurus 2 years
trying to publish gives error 404 message 6 timethief 2 years
Buying a premium template 4 timethief 2 years
Why must readers register before commenting? 2 timethief 2 years
Saving from trash 1 madamemckenzie 2 years
[resolved] Profile Picture Display 1 yukik1011 2 years
Posts Disappeared/Text Gone 2 supportbot 2 years
Blog disappeared 2 auxclass 2 years
Posts are immediately getting liked way too soon after publication 12 timethief 2 years
My "About" page isn't visible. 3 melmannphoto 2 years
Starting a new WordPress account and transferring a blog I've started to it. 1 patriciasmithwood 2 years
To make my emails work can you please add to my DNS server: mx.snap.net.nz 1 rentaroomadmin 2 years
Old wordpress site needs deleting 1 myexercisecoach1 2 years
can't view my blog when i click on the link from Facebook or Twitter 2 thegiddygoat 2 years

New Topic in this Forum

You must log in to post.