Need help? Check out our Support site, then


"400 Bad Request" error message

  1. My blog:
    http://vlemma.wordpress.com
    in Regulus theme, Greek lang., Unicode encoding

    I try to open a post, via an internal link (Dashboard) or the Headline link or the "more" link and instead of the Post page, i see either the message:
    (in Firefox)

    "400 Bad Request
    It is not a valid request!"

    or (in Safari)

    "Doh!

    Something has gone wrong, the page you're looking for can't be found.

    Hopefully one of the options below will help you
    • You can search the site using the search box to the right
    • You could visit the homepage
    • Or you could have a look through the recent posts listed below, maybe what you're looking for is there"

    It's very often... and destructive...
    What's happening?
    I changed theme, but the problem remains.
    It's all right after some time, but then it returns.
    Like a Black Hole, that swallows posts...
    Dissapponting indeed.

  2. My money is that for some reason, your browsers are having an issue with being passed from unsecure pages (http://) to secure ones (https://) since that sounds like where it's occuring. I don't use Macs (I think Safari is Mac only, right?) so I'm hoping someone else can help you with this.

  3. Nope.
    Nothing to do with passing from unsecure pages (http://) to secure ones (https://).
    I am in the main (front) page of my blog (http://vlemma.wordpress.com) and click on the title of a post: http://vlemma.wordpress.com/2006/06/05/Φονικό-από-άγνοια/.
    Result: Doh!

    Nothing to do with Mac either. People using IE/Win and Firefox/Win fail to read some posts of my blog.

    I can see the "missing" posts only in Dashboard Edit mode, not even in Preview mode...
    It seems something happens to cache or database on wordpress.com giving broken links (=400 Bad request)
    Or maybe on the rendering of the post?
    I don't know, but it is serious...
    There is an older thread for the same problem:
    http://wordpress.com/forums/topic.php?id=270&replies=7

  4. Any news?
    The problem continues.

  5. Nikoxy - I have just looked at several of the posts you have there, both on the homepage and by clicking the post to look at comments.

    Using Internet Explorer (on a PC) I get the correct post (I think - I can't read Greek :[ ) every time.

    Do you by any chance have another browser installed on your Mac that you can try?

  6. Cornell,
    thank you very much for test and answer.
    As I have already said the problem is not constant. It is appeared and disappeared.
    On my Mac I have Safari and Firefox 1.5.0.4 installed. Both give the Error message as described, but not all the time. The Black Hole comes and goes.

  7. I'll send in a feedback to give staff a pointer to this thread.

  8. A day or two back I was also getting 400 bad request error. I thought (and still think) that it was something wrong with my ISP. I was unable to access any wp.com blog, even though I could browse everything else just fine. Maybe it is something at the WP end or maybe not.

  9. I also face the same problem of 404 , doh! so was checking for any clues.
    From my observation this is when i get this error,
    * When i click on any link/title, that is in Unicode
    * when i click on 'More' , where i split the post with more tag.

    I guess we can avoid this by Naming the title of post in English rather than in unicode.

    For example if you click on 'MORE' of my post titled 'BATHUKAMMA of DIVINE TELANGANA' it takes you to the URL .,
    http://telanganautsav.wordpress.com/2006/08/29/bathukamma-of-divine-telangana/#more-34
    I think the articles / posts, are saved in the Database with its TITLE, when its given in UNICODE, the query might have been failing giving us those errors.

    This still is my hypothesis, we have to get it confirmed by an expert.

  10. The problem "Error 400" or "Doh!" continues and it is the most annoying in WordPress.com so far...
    I don't think it's the Unicode Title, because it doesn't appear with all the posts or pages. I just don't know...

    Any solution?
    Or any workaround?

    Help! It destroys our blogs constantly!

  11. The bug may be the long non-Latin titles of thw Posts/Pages.
    A workaround is to change the Page Slug at the Edit mode.
    DonAngel gave this workaround and workked for me, with long Greek titles.
    It is here: http://blog.doncho.net/?p=462
    and the thread is here: http://wordpress.com/forums/topic.php?id=2076&replies=21

    Thanks DonAngel!

    THE BUG REMAINS!

  12. I know that Dr Mike has previously put in feedback, can I suggest you do so too?

  13. With a pointer to this thread so that staff knows that we've discussed the matter.

  14. I am having the same problem recently on Safari and Firefox but, oddly enough, NOT on Internet Explorer. I believe that should provide a clue to someone who can figure this out. I don't think this ever happened before and I've been on the internet since the old days when AOL was Mac-only Q-Link back in 1984!

    So any clues anyone? Please e-mail me directly if you come up with a solution because I've tried everything I can think of and this is happening on allthenet.com, the ONLY search engine I like for several reasons (i.e. the ability to customize it in ways the others don't allow and it's MUCH lower level of commercialization - sites with higher rankings being NOT the ones you want but the ones that Paid the most $$$$ to the search engine you're using - Especially that freaking Google monster).

    The most suspicious part of all this is that when I get the Bad Request message it is only on that one site, alltheweb.com, a search engine, and guess where I get the message??? Of all places, I mean you could expect a zillion or three of pages for this to show up, it just so happens that Yahoo's search site comes up with that message? Coincidence? Of several GadZillion web pages that could show me that error it just happens to be another search engine, a competitor??? Coincidence? I think not. That's just a little too "coincidental" for this old fart. I've been around too long to believe in things like weapons of mass destruction that don't exist, never did exist, still don't exist and yet one-third to to one-half of the fools in this country still support the war maiming and killing dead their sons because they refuse to believe what has been proven positively was a LIE! People can be so UTTERLY stupid! Yahoo is hijacking me just as Bush lied. How can I stop it? Explorer doesn't allow it. Why do Safari and Firefox? This is Search Engine/Broswer War! LOL!

  15. OK, Great news! I found a site that mentioned bad cookies which solved this, and I had already removed all cookies with "yahoo" results when doing a search in cookies in Firefox (this is important) - not a manual search but by typing "yahoo" into the text box. That didn't work. So how is this Great news? Something told this old fart, who happens to be pretty good at problem solving, that if it isn't a problem with yahoo cookies then just maybe it's a problem with alltheweb cookies! Did the same thing, a search in the text box, things come up that do NOT have alltheweb in the name (that's why it's so important to use the search that way) and deleted them. Guess what? No more weapons of mass destruction, no more being sent to the yahoo site with a bad request message when trying to go to my old good and trusty alltheweb bookmarked link!! Somehow, it seems, someone at yahoo found a way to put a cookie in there, without yahoo in it's name (which is a crime if you ask me) that hijacked my browswer and sent me to their site instead of the one I requested. There ought to be a law! I'm not fan of frivolous laws by any stretch of the imagination, not even close (and I'm liberal, darned proud of it too) but this is clearly just plain and simple fraud. This is why I use alltheweb not google or ya-freaking-hoo. I've said this sort of thing many MANY times about companies that do these sorts of things, so mark my words, I said it about AOL and they are nearly non-existent now, lost millions upon millions of subscribers since I said it - companies like yahoo, perpetuating fraud on folks like AOL did for so long, they are as good as gone. Yahoo is dead meat. Their stock is tumbling in the not-so-distant future and they will ultimately perish completely. People aren't as dumb as some of these arogant ultra-greedy maniacs think we are. Maybe I was at first, but I and We wise up sooner or later. When will *THEY* learn?

  16. And your point is?

  17. The point is simple but you don't seem to be able to understand so I'll try and explain in even simpler terms for you.

    Yahoo used cookies that were disguised as alltheweb cookies to hijack my browser to their site instead of alltheweb's site. That's fraud. That's illegal.

    Perhaps you don't think that is a problem. It cost me countless hours in delayed browser respsonses and trouble shooting. For over a year I thought my browswer was running so very slowly due to another cause. I searched regularly for updates. I replaced it once with the same version losing several years of bookmarks! I did more maintenance and repair routines on my computer than I needed to. All of that added up to real financial damages as time is indeed money.

    But maybe you think that's ok somehow? What was the point of your question? Is it that you think spyware that does harm to an unsuspecting innocent person's computer is all fine and dandy? They just want to know when I'm on the computer (which is none of their business) and where I'm going (also none of their business) and what I buy (not their business either). It is no different to stall me when I do these things then a person coming out of the shadows and grabbing you by the neck demanding to know where you're going, when and how long you'll be there, and what you're buying before they let you go. It's unlawful detainment. Accosting my computer and robbing me of my time is no different.

    Let's put it this way: If they weren't doing anything wrong then why did they hide their identity by disgusing their cookies to appear to be someone else's? Those who are honest, Unlike Yahoo, aren't afraid of the sun shining on them. They don't operate in the shadows and wear masks, nor do they interfere with other people's freedoms for their own selfish gain.

  18. i have the same problem. and my pages are in english!

    did you figure it out?

  19. Got a link so we can see what the issue is? The blog you have under your user name isn't a wp.com blog.

    If you are hosted elsewhere, you need to be over at http://wordpress.org as you would be runing different software than we are here.

Topic Closed

This topic has been closed to new replies.

About this Topic