Need help? Check out our Support site, then


A link that works only in the post preview

  1. I have made a link in the first post of a new blog. When I see the preview of the post, everything is fine. When I visit my blog, the link does not exist anymore. Why?
    Blog url: http://verbsubg.wordpress.com/

  2. Will you post the html of the link in question?

  3. @inpochisecondi
    Hi there,
    We Volunteer cannot view any "previews". Only Staff have backend access to blogs and can view them. I'm guessing you created an "Aside" by using "Quick Post". Asides do not have titles and we cannot add categories to them.

    Aside – These are brief snippets of text that aren’t quite whole blog posts. Useful for quick thoughts and anecdotes

    If you go to > Dashboard > Posts > All posts you ought to be able to find the post and then you can edit it and chnage the post format from Aside to "Standard". http://en.support.wordpress.com/posts/edit-posts-screen/

    If I did not guess what your issue is correctly then please read on. You may be able to recover an earlier Post Revision. http://en.support.wordpress.com/posts/post-revisions/ Go to Posts > All Posts, hover over the title of the post, click Edit and check the Post Revisions module for previous saved versions of the post. If you're not seeing the Revisions module while on the editor screen, click Screen Options (top right corner of your Admin page) http://en.support.wordpress.com/screen-options/ to activate it. Then select the post and page modules to include them. http://en.support.wordpress.com/modules/#list-of-modules Then you ought to be able to go here > Dashboard > All Posts > Posts and locate the post and recover it from post revisions.

  4. @inpochisecondi
    If that's still not what you are referring to then maybe what you need help with is how to create links in posts and pages. http://en.support.wordpress.com/links/

    This is the general format of a link:
    General link model:
    <a href="URL HERE">Highlighted anchor text here</a>

    You type the anchor text in first. Then you use your mouse to highlight the anchor text ie. to "select" it. Then you click the link icon and the pop-up box appears for you to type the URL etc. into. Do note that the practice of using "here" as anchor text is not a good one at all. The best practice is to use meaningful anchor text such as the exact title and/or keywords in the title in the article you are linking to.

  5. Your link is fine.
    Compare homepage view with single-post view:
    http://verbsubg.wordpress.com/
    http://verbsubg.wordpress.com/2012/06/13/renam-120612/
    On the homepage, the theme you're using displays the beginning of each post. When beginnings are displayed, only plain text shows up: all the coding is removed, so no formatting, no images, no links etc.
    If you wish to make the homepage view identical to the single-post view, you need to copypaste all the content of the post from the HTML editor into the Excerpt module of the editor. If you're not seeing the Excerpt module while on the post editor screen, click Screen Options (top right) to activate it.
    Or switch to a different theme.

  6. Thanks to all of you for your kind answer. The link in the post worked only in the preview section, and when I used the specific post's URL, not when I used the main blog's URL. The problem was resolved when I changed the blog's theme.
    The "wrong" theme was Origin.
    Changing it, everything was and still is fine.
    I can't give any explanation for this, but, changing the theme, everything was ok, without modifying anything about the post.
    Bye. :)

  7. You're welcome, but I did give you the explanation:

    On the homepage, the theme you [were] using displays the beginning of each post. When beginnings are displayed, only plain text shows up: all the coding is removed, so no formatting, no images, no links etc.

Topic Closed

This topic has been closed to new replies.

About this Topic