Need help? Check out our Support site, then


a "non wp user" has to log in to leave a comment

  1. though I have unchecked the adequate box in "discussion" settings, and I require only name + email, and the one who wants to leave a comment does not have a Wp account, my blog requires log in to leave a comment. Thanks for advising. The blog I need help with is http://www.reiseideenkreta.com

    The blog I need help with is reiseideenkreta.com.

  2. Hi there,

    This page > Settings > Discussion is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    Discussion Settings
    Other comment settings
    _Comment author must fill out name and e-mail
    _Users must be registered and logged in to comment

    Note that the prompt to submit and email address and a website URL will still appear, but providing an email address and logging in are not required, and you cannot change this so the prompt does not appear.

    You can post instructions for your visitors in a text widget if you wish to set up anonymous commenting. That's easy to do. You copy and paste this into a text widget:

    Readers: Note that the email address and logging in prompts do appear for comments on this blog, but providing an email address and logging in are not required.

    P.S. Do be sure to set up full comment moderation ie. "An administrator must always approve the comment" because anonymous commenting is bound to increase the amount of spam your blog will receive.
    http://en.support.wordpress.com/settings/discussion-settings/#comment-moderation

Topic Closed

This topic has been closed to new replies.

About this Topic