Need help? Check out our Support site, then


A possible reason Akismet may be filtering comments as spam?

  1. Since yesterday sometime, about ten or twelve of my comments on others' sites have been filtered out the first time I try to put them through. It happens like this: a nearly blank page comes on with the words "Sorry, this comment cannot be posted." I don't know for sure that this is Akismet's doing, but when I saw the sticky post at the top of this page, I thought it might be and wrote them. It has occurred to me that if people use figurative (poetic, non-literal) language such as metaphors and similes in writing, Akismet may be filtering it out as literal spam. For example, I said to someone in a comment that "I have trouble sometimes changing gears," meaning "trouble going rapidly from one activity to another." In this case, I lost the comment to the "sorry, this comment cannot be posted" warning. But as had happened before, when I typed in the message a second time (and rephrased it in this case, though I left it the same in others), it was accepted. Still, I seriously hope that figurative language, part of the wealth of our spoken and written heritage, will not be off-limits due to some malfunction with the Akismet filter. I did express this notion to them in the supposition that it might help. I do know that with some remarks (when I got over my frustration with having to try to remember exactly what I had said before) it was possible just to retype them to get the filter to accept them.

  2. Are you using Talk Talk?

  3. I am having the same problem as an administrator and so are some of my bloggers and it has been going on for over 24 hours. I am getting tired of having my comments go off into oblivion when the "Sorry, this comment cannot be posted" appears. On another thread referencing this problem the following input was given as to why this was occurring. “We’re implementing some extra security checks on comments, but that broke commenting for some users. We’ve rolled back the checks for now, while we work around these problems.”

    Well apparently this roll back has not occurred. Something needs to be done to stop this problem and brought to the attention of the technicians at WP. Becoming extremely frustrating.

  4. No, as far as I know I'm not using Talk Talk, to answer TimeThief's question. I'm just using my own site and commenting on other people's sites the way I usually do. Only if Talk Talk is something that was enabled from the very beginning automatically on WordPress.com could I be using it, so I guess I'm not. No one's ever asked me to, anyway. What is it, and what difference would this make? Thanks for a response.

  5. shadowoperator
    Member

    Hi again. I started out by reading the sticky post at the head of the forum the first thing, which is why I contacted Akismet as requested. But I don't think the "Sorry, this comment can not be posted" which has occurred when I'm commenting on others' sites has anything to do with your suggestion which proved fruitful on your second listed link above (the one which has to do with Talk Talk), because not only am I using Internet Explorer as others who made the "13 replies" were not apparently doing, but I have been using https on my site for months and months now, ever since the last time there was some sort of general problem, and it's been working fine. And also, I've had no other problems of any sort on my own site such as were listed in those 13 replies, only this recent first-time refusal to post on some sites (and as I've said, the remark I try to post, in original or altered wording, is successfully posted the second time I try it each time). Nor have I received any of the other warnings you have listed under "replies=13" above. Thanks for letting me know about it however. If anything else occurs to you before Akismet does their thing, whatever it is, I would appreciate it if you could let me know. And thanks for devoting so much time and attention to the problem already.

  6. This thread was previously tagged for Staff. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  7. Hi shadowoperator, thank you for reporting this issue. Are you still having trouble with it?

    If so, can you please describe exactly what steps you take when it happens, so our developers can reproduce it? Please let us know whether you are already logged in, what URL you start on, what you click on, etc. Thanks!

  8. shadowoperator
    Member

    Hi. Yes, thank you for asking. I am still having trouble with it. I'm not sure what you mean by "what URL you start on," but I'll describe what happens. What happens is that I am answering and viewing comments through my e-mail ([email redacted]). So far, I haven't had any troubles of this sort answering comments to my own site. The URL of my website is https://creativeshadows.wordpress.com, if that's what you mean. But when I click on the "reply" button on the comment for the first time, it takes me to the other person's site to make the comment. These days (with the error message appearing) I dutifully word my message and leave a comment, click, and wait for it to tell me "sorry, this comment cannot be posted." Once it does, I cancel my response (using the little box at the very, very top of my screen which shows the title of the e-mail or note, I'm not sure what it's called, it's not my browser, but it's on that line and I just use the "x" by the words to cancel), re-enter the person's site, and do it again. The second time, it works, whether I re-phrase or not. One thing I have noticed that's different, though, is that the first time when I type, the "notify me of follow-up comments" and "notify me of new posts" messages are both just below where I make the comment (and I always check them, even though I'm already subscribed to the sites I read), whereas when I go in the second time, only the "notify me of follow-up comments" line is below where I make the comment. I hope this helps. I'm sorry I can't be more specific, I don't have all the required "computer-ese" to use the right words for it.

  9. Thank you for these details! I have passed this information on to our developers, who are looking into the issue. I will keep you posted about what they find out!

  10. Hi shadowoperator, our developers have deployed a bug fix that should resolve this commenting issue. Can you let me know if it's fixed for you?

    If it isn't fixed, we have one more question about your process for leaving comments. When you first click on the "reply" button to leave your comment, are you already logged in to your account at WordPress.com? If not, can you describe the steps you take to log in? Thanks!

  11. shadowoperator
    Member

    Sorry to keep you waiting--I had already read all my e-mailed-in comments and had to wait for another one to appear to try the "experiment." I don't think when I first click on the "reply" button to leave my comment that I am logged in to my WordPress.com account, because though it is the WordPress.com form for sending e-mail comments to my e-mail address, until I ACTUALLY click on the reply button on the WordPress e-mail page, the title of the post or comment doesn't appear in the tiny right-hand box at the top of page in the browser line (a locale I don't know what to call, but I mentioned it before). When I click on the reply button, I think it performs a sort of half-and-half login between my e-mail site and WordPress.com, because then it calls up the picture of the post/comment that I want to respond to in the page on someone else's site. I type the reply. BUT THEN I actually hit the WP ICON on the bottom of the form (I think there's also a twitter and another icon there) to formally log in. I log in. I click on "notify me of follow-up comments" and "notify me of new posts" then on "post comment." After it fails, I go back and do it again after cancelling the remark with the "x" at the right-hand side of the box on the right-hand side of the browser line at top of page. And no, it still didn't work today. The only thing I can think of which is possibly an added kink in the situation is that I have Norton security Identity Safe Cards and Logins and Login Assistant on all my logins so that I can type one password and get to any login on my computer and still be safe. But since I only use this just after I hit the WordPress.com logo (the Norton password prompt appears, I fill it in, then the WordPress.com password prompt appears and I hit the button for it), this shouldn't be a problem. In any case, it keeps my computer and all my sites safe with the rest of my Norton paraphenalia, and I would be hard pressed to function without it. I hope this helps.

  12. shadowoperator
    Member

    Hi, it's me again. Sorry to bother you, but just after I wrote the above response and before you contacted me again, I got the comments to work twice, once a comment in response to a comment, and once a comment in response to a post. I don't know if this means it's entirely fixed, but things are looking up! Good job and good luck with making it permanent!

  13. Thanks for all of the details about logging in and for letting me know that it's working for you now!

    If the problem does pop up again, I have another little question about your login process. After you click the WordPress icon and log in, do you see a sentence under the comment box that says, "You are commenting using your WordPress.com account"?

    Hopefully it will keep working and that won't be an issue. :)

  14. shadowoperator
    Member

    Yes, at least some of the time (I can't be sure about all of the time yet, since I wasn't looking for it) the comment "You are commenting using your WordPress.com account" is there. Let's all hope for the best, you guys have been working hard on it!

  15. shadowoperator
    Member

    Hi, Rachelmcr. I was contacted by Akismet yesterday, and I just got finished telling them that this problem had been resolved by WordPress.com, when (today, Friday July 26th) the problem popped up again on one of the sites, and I used my usual second attempt system to post a comment. The first site I tried today didn't have this problem, so it's not all sites, but the second site I posted a comment to today did(and the forum rules below prohibit mention of which particular site it was, but I'll tell you if you want to contact me some other way, perhaps at my e-mail address since you have it on file there, or else give me permission to mention the site). I've been going along quite happily since I told you just above that the problem was solved, but I don't think (I can't be sure) that the site with the problem said "you are commenting using your WordPress.com account." You were so helpful before, a real wizard. Please advise. creativeshadows.wordpress.com

  16. Thanks for the update — I'm sorry to hear that this problem is popping up again! I let our team know and they will look into this issue for you.

    Can you let me know what site you had trouble commenting on? (You can post the link as a reply here.) Were you already logged in to your account when it happened, or did you log in with the WordPress icon in the comment form again? Thanks! If the team has any other follow-up questions for you, I will be back in touch.

  17. shadowoperator
    Member

    Hi. I forum posted as soon as I had trouble yesterday, but because it was my first comment of the day, I didn't realize that in all likelihood it's possibly only that or maybe a few sites that I would still be having trouble with (that is, during the rest of the day, I posted comments without any problem to other sites, and without having to do it twice). The site is http://truthandcake.com/ and the only thing I notice different about it is that when you've almost completed the logging in process and are hovering over the "post comment" button with your cursor, there appears a little balloon that says "really simple syndication," which disappears once you post. That's the only site I've noticed that on. As to whether I was already logged in when this happened, it's as before. I logged in with the WordPress.com icon, but as always, it gives me the remark "You are commenting with your WordPress.com account" before I actually hit the final button. I hope this helps. Kudos on all your hard work.

  18. Thanks for that info! Our team is looking into it to see if we can get this issue resolved once and for all. :)

  19. shadowoperator
    Member

    Hi, rachelmcr. Today is about 6 days since your remark just immediately above, and until today (and except for the http://truthandcake.com blog I reported before) I've had no further problems until today (but today is the weekend, and yesterday was the regular post frequency day of someone I follow who only posts once on the week, so I didn't know until today that I was still having problems with his site too). Since you said it was all right to give the URL of the blog here, I can tell you that URL of the second blog site is http://joeponepinto.com and I do remember having a problem with his site before when trying to post, but as always I just went back in and posted the second time. One thing I think that might be an additional piece of info is that after the three logos are presented the first time I try to post (the wordpress.com logo, the twitter and the facebook logo) and I press the wordpress one and fill in the form and try to post and get the "sorry this comment cannot be posted" remark, even when it also says "you are commenting using your wordpress.com account", on the second time through it only shows the wordpress logo, and sometimes instead of showing both the "notify me of new comments" and "notify me of new posts," sometimes the second time through it only shows the "notify me of new comments" remark. It's not absolutely consistent, but I hope this further info helps. It's been a peaceful, quiet week, but Joeponepinto's site is one I regularly comment on, so I hope we can get it squared away. Thanks for persisting in your efforts to solve the problem. :)

  20. Thanks for the update! I passed along this additional info to our team, and they are looking into it. I'll let you know when I get an update from them. Thanks for your patience with this!

  21. Hi shadowoperator, thanks for your patience with this. Do you have third-party cookies enabled in your web browser?

    If you aren't sure, you can check on this page: Preview Problems and Third Party Cookies

    The commenting issue you describe may be caused by disabling third party cookies. Please let me know if enabling them makes a difference for you.

  22. shadowoperator
    Member

    I don't know how to do all the complicated things that are on "Preview Problems and Third Party Cookies," and I don't have anyone to help me, but when I went to that link, there was a green line of type with a checkmark beside of it that read "Great! Third party cookies are properly enabled on your browser." I have to be careful of what I enable because it interferes (or maybe I don't understand it correctly) with my reception of the Met Opera site I also get. Anyway, if that remark I tell you about above is any indication, I'm all set for third party browsers (but I did have trouble again today with the blog http://joeponepinto.com , same problem as I mentioned last week above. It seems to me that there is a similarity in the two sites I continue to have trouble with, in that neither has the continuation "wordpress.com" in the URL of their blogsite, if that's what you're talking about (the other site was http://truthandcake.com/).
    Does the green line of type at "Preview Problems and Third Party Cookies" mean that I'm okay? Thanks for keeping up with this.

  23. The message you saw on that page ("Great! Third party cookies are properly enabled on your browser.") means that you have those cookies enabled, so that's good. When WordPress.com sites have custom domains (meaning they don't have .wordpress.com in the URL) you need third party cookies to make sure you stay logged in when you visit the site and leave comments.

    However, even if you have these cookies enabled, it's possible to block cookies for specific sites. That can cause the problems you're having with comments on those sites. You'll need to make sure that cookies aren't blocked for the sites you're having trouble with (such as joeponepinto.com and truthandcake.com).

    If you use Internet Explorer, you can use this guide to manage cookies in your browser:

    http://windows.microsoft.com/en-us/internet-explorer/delete-manage-cookies

    On the Privacy tab in Internet Options, you can click on "Sites" to manage cookie settings for specific websites you visit. You can enter each website you are having trouble with, and set it to always allow cookies on those sites.

    Please let me know if you have any questions about that. If you continue to have trouble leaving comments after checking those settings, let me know.

  24. shadowoperator
    Member

    Thanks so much for the explanation, and all the hard work you've put into this for several weeks now. Though the saying is "comparisons are odious," I think you are one of the most hard-working "happiness engineers" I've ever encountered, though I know you also have said you're relying on the help of your colleagues and cohorts for help. Kudos to all, and I will either do one of two things (I'm a little nervous about enabling third party cookies for sites that might cause a security problem). I will either go ahead and use your system and enable them as you describe, in which case if it doesn't work I'll be back in touch, or I'll make a habit when I visit those sites of just typing in some short comment like "Hi, great post" for the system as it is to demolish and then wait for the second time around to type my real comment. Thank you again for describing to me exactly how to correct the problem with Internet Explorer, and I hope you get a great vacation this summer! :-)

  25. Thank you for your kind words. :) If you do make the changes to enable third party cookies on those sites, please let me know how it works for you. If there's something else going on here, we'd be happy to investigate it!

Topic Closed

This topic has been closed to new replies.

About this Topic