Need help? Check out our Support site, then


A way to stop Safari stripping line breaks

  1. OK, we all hate the way that Safari 3.0.x strips out line / paragraph breaks when we use the Visual Editor. As we all know, this is a limitation of WordPress / TinyMCE / Safari, which is (hopefully) under development for a fix.

    In the meantime, there is a way round it - for Mac users anyway - that means you don't have to change browsers just to post to WordPress. I've done some limited testing on this process and it seems to work, but I've not had a chance to use it extensively so don't know yet if it breaks anything else. As always, if you're going to try this, take precautions!

    1. If it's open, close down Safari.
    2. Open Terminal
    3. At the prompt, type this: defaults write com.apple.Safari IncludeDebugMenu 1
    4. Start Safari.
    5. If you've done it right, you'll see that you have a new "Debug" menu item. Click this.
    6. Select "user agent"
    7. Select a browser that isn't Safari. I chose "Firefox 2.0.0.2"

    That's it.

    I've only tested this fix on Safari 3.0.x - but then Safari 2 never had the same problem - but it has allowed me to write and edit posts using the Visual Editor and without losing line breaks.

    If someone out there can hack the Windows version in a similar way, then this problem might finally be solved.

  2. Well, ongoing testing reveals that this fix may only work for us here at WordPress.com, not for WordPress.org self-hosted blogs.

    Testing continues...

  3. The real fix will be when TinyMCE makes their editor work with Safari without a terminal hack.

  4. @tsp
    Very true. I found this 'solution' over at WordPress.org, where the debate on the subject is even more heated - some say it's Apple's fault, some say it's WordPress, some say it's TinyMCE and some blame all three.

    Further testing is revealing patchy results, wherein sometimes some of the line breaks disappear and sometimes they don't. It would seem to be an 80% solution - OK for those who don't need to edit their posts too much but not brilliant if you're the type of blogger (like me) who hacks around with their posts several times before being completely happy with them.

    Having used Safari for a couple of hours while I've been testing this, I have to say that I while I was a big Safari fan when I first got my Mac I didn't like going back to it after using Flock for a few weeks.

  5. Yeah I hear what you are saying. I think all three share some blame, but being a longtime Mac and Safari user, I know that Safari has always had some problems (in other areas), so Apple is not blameless, but neither is TinyMCE. I expect they were a little reluctant to work on it since Safari had a small portion of the browser market although that is changing as Apple's market share increases. I have heard that there is at least one javascript-based online editor out there that is fully compatible with Safari but cannot remember the name. It can be done.

    I'm like you though, although it is that I'm getting spoiled by the plugins that are available for Firefox such as Firebug and WebDeveloper, both of which I use daily.

  6. One thing about this fix to watch out for-- the user agent setting only sticks for the *current* browser window. If you make a new window, it reverts to "Automatic".

  7. Hmmm...this problem is annoying. I'm about to give up on WordPress and try something else.

  8. @deanwette

    Two suggestions: Download and use Firefox for doing your wordpressing until Safari becomes compliant (TinyMCE is working on it) or get yourself an offline blog editor such as Qumana or Ecto. Qumana is a free download and Ecto is about $20US. I use Ecto but Qumana seems to work well in the little testing I did. I like using an offline editor because I always have copies of all my posts right on my hard drive and I don't have to worry about losing anything if there is a glitch in wordpress while saving or publishing a post.

  9. To me, it's a no brainer and I would be using an offline editor no matter where I was blogging since anytime you are dealing with an online editor, there is a much greater possibility of there being a problem such as with your internet connection, an internet network issue, or a problem where you are trying to post.

  10. Total novice here -- I can't find "Terminal" mentioned in step two. Any advice?
    Thanks.

  11. Terminal is in the utilities folder in the application folder.

  12. Thanks so much! I found some advice you gave another novice on a similar topic and decided to go with Firefox. About to see how that goes. Best wishes.

  13. You're welcome. Firefox should do well for you. I've been using it for ten months and have been quite happy with it. I must say though that I prefer Safari for web browsing and such. I'm hoping that one day in the not too distant future the TinyMCE editor used by WordPress will be compatible with Safari.

Topic Closed

This topic has been closed to new replies.

About this Topic