Need help? Check out our Support site, then


Active link in post [Solved!]

  1. Message to WordPress coders and also for anyone who was/is trying to add an active link to a post via the "link" button, you will notice the link doesn't display on the post.

    I was going to ask if anyone here was experiencing the same dilemma, when I solved the problem by comparing the "link" button here in the forum with the "link" button in the post creator, i.e. the syntax code. The top one is from the post and the second is from the forum.

    WORKING

    WORKING

    I hope this helps you and I hope too that the WordPress coders will see this and make the necessary changes. thank you - Mús

    The blog I need help with is thesleepymoose.wordpress.com.

  2. I thought it would display the code in the quote. How and ever, I am placing the code below with the active link opener and closers, i.e. bracket a bracket & bracket /a bracket.

    href="http://thesleepymoose.wordpress.com/" title="NOT WORKING " target="_blank">

    href="http://thesleepymoose.wordpress.com/" target="_blank">WORKING

    This mightn't be explained as well as it should be, so if you have any questions, just ask. Or if you can explain this more clearly, please do. - Mús

  3. Here is the support document about adding clickable links to a post or page:
    http://en.support.wordpress.com/links/

    The key to making text into a clickable link is:

    Highlight the text you want to link.

    In html the link should look like this:
    <a href="http://URL_OF_LINK">LINK_TEXT</a>
    If you want the link to open in a new window:
    <a href="http://URL_OF_LINK" target="_blank>LINK_TEXT</a>

    you must have the opening and closing "a" tags.

  4. Thank you, you are corrent, but the problem still lies with the "link creator button" when writing a post.

    It gives the following code <a>href="http://thesleepymoose.wordpress.com/" title="NOT WORKING " target="_blank"></a>
    instead of
    <a>href="http://thesleepymoose.wordpress.com/" target="_blank">WORKING</a>

    So by adding

    title=""
    as the link text, it makes it obsolete and so doesn't display in the page/post.

    (I just realised how to post code here. Trial and error - one of the best ways to learn anything ;) )

  5. I don't understand what you mean or what you're trying to do. As Tess said, the linking text must be typed in the editor, then highlighted; then you click the link button and paste the URL, tick the new-window option if you wish, and click Add Link. Adding a title is totally optional, and it's not supposed to be the linking text: it's an additional description that shows up when you mouse over the link. For example, the linking text might be "click here" and the title "Support doc on adding links".

  6. Thank you. I understand exactly how it works now. I was clicking Add Link and thinking "title" was the linking text. I guess I've just taken another step forward on the path to WordPress enlightenment. Thank you both for your assistance! :)

  7. You are welcome!
    We all were newbies once. Even babes without a clue! Life is learning.

    The attempt and not the deed confounds us.
    William Shakespeare

Topic Closed

This topic has been closed to new replies.

About this Topic