Need help? Check out our Support site, then


Adding pages without adding them to the menu

  1. I am trying to build a professional site for my freelance writing business using WordPress. I have a "Portfolio" page (a parent link) that will have lots of links to other pages I have created of articles that I have written. I want to post these pages without the links appearing on the right-hand menu under the "Portfolio" link. Doing so would create an unmanagably long list of links. I am using the Jentri theme by Phu.

    Any help would be appreciated.

    The blog I need help with is robertfraass.wordpress.com.

  2. The site linked to your name is not a blog on WordPress.com, and we won't be able to help you with that. If you have a WP.com blog, please provide a link to it, starting with http.

  3. Whoa ... not sure how that is linked to my old website. My WP.com blog is http://robertfraass.wordpress.com. I'll see if I can fix the site linked to my name.

  4. You'd change that on your Profile page, under Website.

    If you use the Pages widget, you can exclude whichever pages you want from being displayed. Just put them in the "Exclude" box one by one.

  5. Ok ... My profile is now linked to my WP blog: http://robertfraass.wordpress.com. Any thoughts on my question? Thanks in advance.

  6. See my answer above.

  7. This explains how to find the page ID's: http://support.wordpress.com/widgets/pages-widget/ .

  8. Makes sense ... I will give that a shot. Thank you!

  9. Apparently, I am dense. I found the page IDs. But when I go to my Profile page, I don't see anything listed like "Website" like raincoaster mentioned. I went to Page>Edit, but there is no Pages menu with an Exclude box anywhere like is shown in the short video. Apparently I am missing something. I don't think I am getting to the actual Page Widge page or perhaps I did something wrong in setting up my pages.

    The tutorial was simple, but I can figure this out. Thanks.

  10. Woo-hoo! Never mind. I just never added the Pages Widget for the Apperance menu. I think my problem is resolved. Thanks for the help.

Topic Closed

This topic has been closed to new replies.

About this Topic