Need help? Check out our Support site, then


Adding widgets has changed and I'm lost

  1. I've been adding widgets to my blog for almost a year now with no problem. All these times when I click on widgets, it showed a list of widgets that you can choose from and all I did was simply drag the widget I wanted to the sidebar, put it in the place that I wanted it to be, fill in the info, click and saved and there it was on my blog page. Now all I see when I click on widgets is a long list of widgets and an "appearance" and "save" button or something like that. It gives me no options on where to put the widget on my blog page. There is no place to drag it TO.

    What I want to do is put a link on the side of my blog (where my facebook link is, my avatar, my blogs that I follow etc. The link I want is to be amazon where I want to link to the book I have just published.

    So what has happened? Has the way we add widgets changed (obviously it has) . I have no idea how to do it now. I've put the link in the area that was displayed and all that it asked for, hit "saved." But there is nothing new on my blog page. Please help me! Thank you.

    The blog I need help with is welding81.wordpress.com.

  2. Hello Gatito2,

    I am using the latest version of the Mozilla Firefox internet browser on a desktop computer on Ubuntu Linux 12.04.4 with the latest version of Adobe Flash Player (http://get.adobe.com/flashplayer/) installed, and I am not having this problem; and so you might/may be having a browser problem.

    Here is how it looks for me:

    https://mediacru.sh/V76fOpWDSh4q

    Make sure that you click the downward facing triangle-like icon next each Sidebar/Footer Name to open it so that you can drag and remove Widgets (http://en.support.wordpress.com/widgets/#adding-widgets) to and from it

    I also recommend trying some of the suggestions on the Browser Issues Support Page to see if that helps:

    http://en.support.wordpress.com/browser-issues/

    And/Or try some of Timethief's suggestions that she listed here:

    http://en.forums.wordpress.com/topic/follow-button-widget-follower-count-not-showing-properly-in-many-themes?replies=10#post-1534123

    Good luck,
    -John Jr

  3. Thank you John Jr. The way your widget page looks is just like mine used to look but does not anymore. It looks like this (if you can see it) http://welding81.wordpress.com/wp-admin/widgets.php

    I've tried some of your suggestions. I updated my adobe flash player, I cleared the cache, I got google chrome, I already have Internet explorer 9. I can't think of anything else to do. What yours looks like is what mine has always looked like until I looked at it today. But it has been months since I went to my widget section. My page just does not look like the widget page where you can drag what you want to the sidebar. You can't even see a sidebar on what I see now, only a list of widgets that you can do nothing with.

  4. I already have Internet explorer 9

    The most recent version is IE11 not 9.

    1. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode. http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    3. If you are running one of the browsers and versions listed at http://browsehappy.com/

    (a) Try clearing your browser’s cache http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:
    http://browsers.about.com/od/howtousemobilebrowser1/ss/safari-ipad-clear-cache.htm
    http://browsers.about.com/od/howtousemobilebrowser1/ss/How-To-Clear-Browsing-Data-In-Chrome-For-Ipad_6.htm

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled
    http://en.support.wordpress.com/third-party-cookies/
    http://www.google.com/adsense/support/bin/answer.py?answer=12654

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS: http://en.support.wordpress.com/https/

    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions

    4. You can use this link to see if your flash is up to date. http://www.adobe.com/software/flash/about/ If it’s not then go to http://www.adobe.com/products/flashplayer/ and download and install the latest version of flash.

    5. Try using another browser.

    6. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to WordPress.com.
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/
    (c) Exactly what you experience including what any error reports you receive state.

  5. @Gatito2

    You are welcome Gatito2, but your link will not work for me so I can not see how it looks from your point-of-view; but you can make a screenshot (http://en.support.wordpress.com/make-a-screenshot/) and either upload it to your Media Library (http://en.support.wordpress.com/media/media-add-new/) or to a service like MediaCrush (https://mediacru.sh/), and post a link to the screenshot here so that we can view it.

    Timethief is correct about your Internet Explorer (http://windows.microsoft.com/en-us/internet-explorer/download-ie) version being out-of-date, depending on what/which version of Windows you are using because some older versions of Windows do not support the newest Internet Explorer versions if I am not mistaken, what version of Windows are you using Gatito2?

    Also is it working in the latest version of Google Chrome (Version 33 I think but I could be wrong) or Mozilla Firefox (http://www.mozilla.org/en-US/firefox/new/) for you?

    You should probably try Timethief's suggestions if you have not tried them already. (Thank you Timethief for posting them here directly ;))

    You probably should also make sure that Windows is up-to-date by checking for updates through Windows Update/et cetera (http://www.update.microsoft.com), make sure that your graphics/video card drivers are up-to-date and/or installed (Windows Update usually shows available drivers when there are updates, depending on your hardware), make sure that your monitor/screen resolution/size is set large enough, and/or make sure that your browser is maximized so that you can see more of the page.

    Maybe even do a malware scan with whichever anti-malware program/software you use just in case to make sure that your computer is not infected with malware that could be causing problems, if you have no anti-malware program/software installed you can use Microsoft Security Essentials (http://www.microsoft.com/security/pc-security/microsoft-security-essentials.aspx) which is free and has both real-time and on-demand protection.

    Anyway, sorry for the overload of information/links, and let us know if you still need help. ;)

    -John Jr

  6. John jr, I tried to do a screen shot (not familiar with that) using the tab on the keyboard the way the instructions said...nothing happened. I have tried to upload my Explorer 9 to 11 but it fails every time I do it. I've tried twice. But 9 or over they say is sufficient and I've not had any problems with widgets before. I have Window 7 and have the whole 11 months I've been on WordPress. My computer must have some type of problem because it won't let me upload explorer 9 to 11 and it also won't complete my new computer updates. Something must be wrong there. But STILL everything else on my wordpress works fine. Anything else I want to do, post, comment, click on my links and everything works fine except widgets. It just does not look like it once did and does not have the drag boxes and the box to drag it to that once was one the right. If everything else is working, I don't understand why this is not.

    At any rate, I'm certainly not a computer whiz and some of these fixes are beyond me and my brain is about to explode. I've been messing with this all day almost. And unlike my nature, I'm simply giving up and do without the link to the book I just published which is REALLY a let down, but I don't know how to fix my problem.

    Thank you and the other nice person for trying to help me, but I believe this is beyond me.

  7. Here's a sample I copied and pasted of part of the way my widget screen looks now: (also it gives instructions to "drag" the widget, but there is nothing to click on to drag or a sidebar to drag it to anymore.

    Widgets

    Available Widgets Deactivate

    To activate a widget drag it to a sidebar or click on it. To deactivate a widget and delete its settings, drag it back.

    About.me Widget

    About.me is a free service that lets you create a beautiful one-page website all about you.

    Current users simply copy and paste your full about.me URL in the box( http://about.me/username ) below. Or, sign up, create a page then add your full about.me URL here.

    Widget title:

    Your about.me URL:

    Photo:Background ImageBio PhotoNone

    Name:Display X-LargeDisplay LargeDisplay MediumDisplay SmallDon't Display Name

    Headline:

    Biography:

    Apps:

    Delete | Close

    Visibility

    Display your about.me profile with thumbnail

    Akismet Widget

    Title:

    Delete | Close

    Visibility

    Display the number of spam comments Akismet has caught

    Archives

    Title:

    Display as dropdown
    Show post counts

    Delete | Close

    Visibility

    A monthly archive of your site’s Posts.

    Author Grid

    Title:

    Display all authors (including those who have not written any posts)

    Avatar Size (px): 16x1632x3248x4896x96128x128

    Delete | Close

    Visibility

    Show a grid of author avatar images.

    Authors

    Title:

    Display all authors (including those who have not written any posts)

    Number of posts to show for each author: (at most 10)

    Avatar Size (px): No Avatars16x1632x3248x4896x96128x128

    Delete | Close

    Visibility

    Display blogs authors with avatars and recent posts.

  8. @Gatito2

    You are welcome, I recommend taking your time and moving at your own pace whenever you feel like it and slowly trying our suggestions in order exactly following the directions and the text/images/sometimes videos examples given or search for video guides on YouTube (https://www.youtube.com/) and/or search for guides/information/examples/et cetera online through a search engine, and you can ask questions here whenever you can not figure something out after following the directions/images/videos/et cetera. ;)

    Sometimes it can be or seem over-whelming but it is not as hard as it seems if you take your time, take a deep breath and use your past knowledge to help you solve problems as you follow the directions, and ask for help when needed; and usually that is enough to figure it out. ;)

    Good luck,
    -John Jr

  9. @gatito2
    What I posted above here is relevant.
    http://en.forums.wordpress.com/topic/adding-widgets-has-changed-and-im-lost?replies=8#post-1718914

    Until you deal with what I posted above and report your computing environment details back to us the rest of this dialog is just falalalala that will get you nowhere.

  10. P.S.

    I have tried to upload my Explorer 9 to 11 but it fails every time I do it. I've tried twice. But 9 or over they say is sufficient and I've not had any problems with widgets before. I have Window 7 and have the whole 11 months I've been on WordPress. My computer must have some type of problem because it won't let me upload explorer 9 to 11 and it also won't complete my new computer updates.

    The most recent version is IE11 not 9.
    1. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note what I posted above please and try downloading Firefox.

  11. Everyone, I'm just exhausted with all these things I'm trying to do that simply do not work. My computer will not do some of the things that are suggested because undoubtedly something is wrong with it. I think my biggest problem is my computer is failing when it's trying to upload Windows updates. I can't update to Windows 11 or any of the other updates it prompts me to do. It says "updates failed" and I can't figure out why they have even when I search for solutions as prompted.

    So in order not do do anymore "falala" with you all and waste your time until I get my computer issues resolved by a computer expert actually looking at my computer, I decided to log onto my wordpress blog using my deceased daughter's mac. Of course on there the widgets show up just like they should. I thought I would just do what I wanted there. Then I discovered I can't find an appropriatete widgit that would let me show a link and clickable picture of my book on my sidebar. I tried a few and they were not the one's that would allow me to do that. Does it even exist?

    My daughter took her own life 4-11-13 as a 3rd year medical student. I wrote about her, depression, and suicide and I want the book on my sidebar to show up because it is important to me. I know that part may not sound relevant, but just wanted you to know why I'm so frustrated that I can't do what I want to do.

    You don't have to tell me anymore possible fixes to my computer because it's obviously something I need to get fixed by an expert in person, just let me know if there is a widget that I can do what I want to do with it that I can use and I will use my daughter's Mac to do it.

    Thank you all.

  12. I decided to log onto my wordpress blog using my deceased daughter's mac. Of course on there the widgets show up just like they should. I thought I would just do what I wanted there. Then I discovered I can't find an appropriatete widgit that would let me show a link and clickable picture of my book on my sidebar. I tried a few and they were not the one's that would allow me to do that. Does it even exist?

    Hooray! You are up and running on a Mac.

    Yes. You can use the image widget or the text widget.
    http://en.support.wordpress.com/widgets/image-widget/
    http://en.support.wordpress.com/widgets/text-widget/
    http://en.support.wordpress.com/widgets/text-widget/#adding-an-image
    Here are more details about the options for uploading images http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/
    For troubleshooting images see here > http://en.support.wordpress.com/images/troubleshooting-images/

  13. I decided to log onto my wordpress blog using my deceased daughter's mac. Of course on there the widgets show up just like they should. I thought I would just do what I wanted there. Then I discovered I can't find an appropriatete widgit that would let me show a link and clickable picture of my book on my sidebar. I tried a few and they were not the one's that would allow me to do that. Does it even exist?

    Hooray! You are up and running on a Mac.

    Yes. You can use the image widget or the text widget.
    http://en.support.wordpress.com/widgets/image-widget/
    http://en.support.wordpress.com/widgets/text-widget/
    http://en.support.wordpress.com/widgets/text-widget/#adding-an-image
    Here are more details about the options for uploading images http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/
    For troubleshooting images see here > http://en.support.wordpress.com/images/troubleshooting-images/

  14. I have the same problem

  15. Which one? Did you try all the things that the people above suggested? What browser and version are you running?

  16. I just want to thank you all for helping me. As it turns out, I had downloaded Chrome as someone's suggestion the other day but I was so overwhelmed with possibilities on how to fix the problem, that I did not actually go to my blog using that browser. I did this today and everything shows up fine using chrome. The widget area shows up just how it was supposed to. So now my problem in getting those widgets on my sidebar is fixed. It must have been a browser problem. However there is still a problem obviously with Internet Explorer but I won't worry about that now. Now I have my book link proudly displayed on my sidebar as well as a Facebook link to my Facebook book page.

    Thank you all!

  17. @gatito2
    I'm so happy to read that. Best wishes for happy and trouble-free blogging from here on.

  18. Hello Gatito2,

    Thank you for the update and for the good news, congratulations, and you are welcome. :)

    -John Jr

  19. gabriellawestberg
    Member

    Hello, I'm having the same problem as Gatito2. An additional problem is that I'm stuck in a fortress of IE9 and no possibility to download or upgrade anything without the whole company having the same at the same time. Which the IT-security people are not into.

    But I also need to handle the widgets on our blog! So if you have any other solution than to upgrade to IE11 or another browser, please tell me how!

    Thanks in advance!
    /Gabriella (with the blog http://www.kollegaredaktionen.se)

  20. I tried using Chrome, as suggested, and was briefly delighted that the widget paged looked familiar. I added the Text to the Content Sidebar and typed my message, but when I looked for the Visibility Button ... nothing. I'm using the Twenty Fourteen theme, and in IE it had the option of showing particular Text widgets on particular pages and hiding it from others. You can't do that in Chrome.

    I didn't want to go near Windows 8 until they'd got their act together. My sister is still having difficulties.

    For me, the simplest answer is to delete all my Sidebar widgets as I only got halfway through setting them up before everything got stuffed up. I wonder how long it will be before I won't be able to blog here at all.

  21. @Gabriellawestberg

    Hello Gabriellawestberg,

    If your company is forcing you only to use Internet Explorer 9 (which is unfortunate) I recommend that you follow all of our advice that we already listed above that does not involve using another browser or upgrading Internet Explorer or that goes against your company's policies (skip the parts that your company will not allow you to try (ask them if your are not sure) and follow the rest of our advice exactly, and if it still does not work after that let us know):

    WordPress.com Browser Issues Support Page:

    http://en.support.wordpress.com/browser-issues/

    Timethief's Advice:

    2. If you are using an IE browser in compatibility mode please disable that mode. http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    3. If you are running one of the browsers and versions listed at http://browsehappy.com/

    (a) Try clearing your browser’s cache http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled
    http://en.support.wordpress.com/third-party-cookies/
    http://www.google.com/adsense/support/bin/answer.py?answer=12654

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS: http://en.support.wordpress.com/https/

    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions

    4. You can use this link to see if your flash is up to date. http://www.adobe.com/software/flash/about/ If it’s not then go to http://www.adobe.com/products/flashplayer/ and download and install the latest version of flash.

    6. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to WordPress.com.
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/
    (c) Exactly what you experience including what any error reports you receive state.

    My optional extra suggestions (if your company allows it, check with them first, because they probably will not allow some or most of them):

    You probably should also make sure that Windows is up-to-date by checking for updates through Windows Update/et cetera (http://www.update.microsoft.com), make sure that your graphics/video card drivers are up-to-date and/or installed (Windows Update usually shows available drivers when there are updates, depending on your hardware), make sure that your monitor/screen resolution/size is set large enough, and/or make sure that your browser is maximized so that you can see more of the page.

    Maybe even do a malware scan with whichever anti-malware program/software you use just in case to make sure that your computer is not infected with malware that could be causing problems, if you have no anti-malware program/software installed you can use Microsoft Security Essentials (http://www.microsoft.com/security/pc-security/microsoft-security-essentials.aspx) which is free and has both real-time and on-demand protection.

    WordPress.com Advanced Browser Issues Page (Probably too advanced, you can probably skip this, unless someone from the WordPress Team asks for it or something like that):

    http://en.support.wordpress.com/browser-issues/advanced-browser-troubleshooting/

    @Cherriezell

    Hello Cherriezell,

    I never use the Visibility Button and so I did not realize that it was gone until you mentioned it, but when I click on the Widgets in the list of Available Widgets there are some hidden Options there that probably used to be under the separate Visibility Button, please check those hidden Options and let me know if those are the options that you are looking for.

    @Raincoaster

    Hello Raincoaster,

    Do you have any extra suggestions for them that we missed?

    Thank you for the help.

    Good luck everyone,
    -John Jr

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags