Need help? Check out our Support site, then


After enabled https, couldn't edit my profile

  1. Hi, I turned on the HTTPS in my setting, and saved it, but after that, I couldn't open any admin pages again including create new post, edit my profile...

    I tried different web browser and got the same result. Safari says 'Safari can’t open the page “https://oujinliang.wordpress.com/wp-admin/profile.php”' and IE says 'Internet Explorer cannot display the webpage'

    Anybody can help on this? Thanks in advance,

    The blog I need help with is oujinliang.wordpress.com.

  2. yes, I have followed the instructions and cleared the cookies, I even downloaded a different browser and tried it, still doesn't work.

  3. That should only be part of the error.

    Can you please quote the entire error message?

  4. This is what Firefox says:
    The connection was reset

    The connection to the server was reset while the page was loading.
    The site could be temporarily unavailable or too busy. Try again in a few
    moments.
    If you are unable to load any pages, check your computer's network
    connection.
    If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.

    and Chrome:
    SSL connection error
    Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have.
    Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error.

  5. That's rather odd. If that were the case, no one else would be able to connect here via HTTPS, including myself.

    Can you access other HTTPS sites?

    For example, https://www.google.com/accounts/

  6. yes, I can access https://www.google.com/accounts/ .

    I'm not able to connect to wordpress https even on different computers and OS (Windows and MacOS).

  7. [tip] Another way to edit your profile is Gravatar. Visit http://en.gravatar.com/profiles/edit

  8. oujinliang, this is quite strange.

    Are you running any third-party firewall or security software? If so, would you please try temporarily disabling those?

    If that doesn't solve the problem, please try resetting your modem and/or router.

  9. I got it, the 'great firewall of China', super shit.
    It's resloved by using a proxy, thank you all.

Topic Closed

This topic has been closed to new replies.

About this Topic