Need help? Check out our Support site, then


After logging in, I can't really do anything!

  1. brendanberkley
    Member

    When I log in, I see the admin bar, the WordPress.com logo, the row of links starting with "New Post", and then the four columns of links across the bottom. Nothing else. And when I click any of the seven links, nothing happens!

    I've tried this with this account, a different account I just created last week, and I've tried in FF 14, Chrome 20, and IE8 and 8/7 Compatibility Mode. In Chrome, I wiped the cache cookies and history and tried again, and...nothing.

    Any help would be appreciated!
    Cheers,
    Brendan

  2. Can you provide us with the blogs address so we may be able to help you better?

  3. brendanberkley
    Member

    brendanberkley.wordpress.com - I should also note that I am able to get into the admin section for each of the two blogs associated with this account. The problem is not there, though I did notice a little quirk that the rollover menus don't seem to work for me in the dashboard.

  4. Hi there,
    IE7 is not supported but IE8 and IE9, FF 14 and Chrome 20 are supported. These are the troubleshooting steps we take whenever any issues like this arise:
    clearing your browser cache and cookies > http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050
    using the browser with all extensions or add-ons disabled
    updating the browser to the latest stable version (not a buggy BETA browser version) http://browsehappy.com/
    confirming third party cookies is enabled http://support.google.com/accounts/bin/answer.py?hl=en&answer=61416
    confirming JavaScript is enabled http://www.google.com/adsense/support/bin/answer.py?answer=12654
    confirming Flash is updated http://www.adobe.com/software/flash/about/ and if required installing the latest version of Flash http://www.adobe.com/products/flashplayer/
    resetting your router and modem and rebooting your computer

  5. brendanberkley
    Member

    I'll look into Flash, but I think everything else is addressed or irrelevant. I noticed the #! in every single URL that I'm having trouble with...is that an AJAX thing? Does wordpress.com query a CDN that my proxies at work might have blocked?

  6. brendanberkley
    Member

    Looking into it more, I definitely have some kind of a JavaScript problem. If I disable JavaScript, I see the notification "Please enable javascript to continue using WordPress.com." When I re-enable and reload...nothing happens. I don't get the home-nav tips and nothing is loading into the div "tab-content". JavaScript works on other web pages, but not on WordPress. The fact that this happens across browsers tells me that something might be getting blocked by my office's Internet filter.

    Can someone tell me some server names where the JS files are hosted? I was looking at the source code and boy, it's messy. So any help would be appreciated :)

  7. Hi there,
    I have flagged this thread for Staff attention.

  8. brendanberkley
    Member

    Thanks!

    The only thing I've caught so far is that my Gravatar is blocked by the filter. Don't think this would be causing the other problems though? Will keep poking around.

    The goal here is to get a URL for our IT guy to whitelist.

  9. brendanberkley
    Member

    Hey! Just did https://wordpress.com instead of http:// and everything works. So, I have a workable solution, but if someone would still be willing to help that'd be great because I'd like to figure out definitively where the problem was.

    Why would going to SSL cause the JavaScript to start working?

  10. Aha! One of my troublsehooting tips worked. That's great news.

    Why would going to SSL cause the JavaScript to start working?

    I don't know and I'm waiting for Staff to provide a response to that when they get to this thread.

  11. brendanberkley
    Member

    With our filter, a site like Twitter can be blocked but using the encrypted URL works. I'm guessing that something like that is happening here, but I can't pinpoint the script that's getting blocked.

  12. Yes, using SSL re-routes your connection a bit, so you're probably able to get past the filter in that case.

    SSL is actually far more secure anyway, so I recommend just sticking with that.

  13. brendanberkley
    Member

    Well, that's fine for me :) But I won't be the only one in the office on WordPress, and others will be a little less experienced in such matter. I noticed as I clicked around that being on the SSL side doesn't mean I'll stay there - I had to retype https more than once. So I'd like to solve this.

    Today I went into Firebug with the SSL version and the unsecured (insecure?) version and took a look at all of the scripts that each version was referencing. I noticed that the secure version referenced public-api.wordpress.com/rest/v1/proxy while the unsecured one does not. I went to look for it in the source code and was unable to find it, which told me that it was probably buried in another JS.

    Unless the AJAX stuff is happening elsewhere?

    I understand that this isn't really your problem, but you guys know your site's structure way more than I do. The more I dig in the more I realize just how complex it is! Any help would be appreciated. Maybe someone else running Trend Micro will benefit from this down the road :)

  14. Hm, you shouldn't have to re-type https.

    At Users -> Personal Settings in your Dashboard, have you checked "Always use HTTPS when visiting administration pages"?

  15. brendanberkley
    Member

    I did not know about that setting. I think that that should be enough to give me a good workaround to pass on to others.

    Thanks for your help - I don't like leaving a problem unanswered but at least I have something that works predictably now!

  16. I think the problem is Javascript isnt compiling finely.

Topic Closed

This topic has been closed to new replies.

About this Topic