Need help? Check out our Support site, then


Am I using WordPress 2.5?

  1. Hi, there. I just launched a new blog last week using the DePo theme. How do I know which version of WordPress I'm using? I've read some good things about version 2.5 and want to make sure I'm using it. Thank you.

    The blog I need help with is peacepolicy.nd.edu.

  2. wordpress.com does not officially use a certain version of WordPress, but I think you can safely assume that it's at least the latest version, which would be 2.8.4.

  3. You can always typically think of it as whatever the current version is "+". Much of the time we are actually running on a hybrid of the current version + some of the next version that is being worked on.

Topic Closed

This topic has been closed to new replies.

About this Topic