Need help? Check out our Support site, then


approved comment not showing

  1. hi
    wonder if anyone has any insight into a problem I'm experiencing...
    I've received a comment which I approved but it only seems to be visible on a page of my site that is accessible internally (i.e. I can only see it as a comment under my post when I access it through dashboard-> comments -> view attached page). When I go to the post externally (i.e. not via dashboard), the comment is nowhere to be found, even though it has an approved status...
    It seems that the comment exists on some variation of the post page that kind of exixts only to display the comment (this one: http://gosiasdrawer.wordpress.com/2012/08/10/japanese-design/japanese-design/#main) and which isn't accessible by regular navigation within the post...
    How do I go about solving this?
    (the post I am on about is http://gosiasdrawer.wordpress.com/2012/08/10/japanese-design/)

    thanks!

    The blog I need help with is gosiasdrawer.wordpress.com.

  2. hello again,
    I still need help with this one... is there a reason why I am not getting any replies? :(

  3. right, I fidddled with the pages of my blog, have done some self-exploring and discovered what seems to be the root of the problem. As my site is a design one, I have a number of images on it and, wherever a single post has more than one image and/or gallery inserted then: by right clicking any gallery image and choosing 'open link in a new tab/ window' the viewer gets an access to ALL the images I have ever published under that particular post, even those I have chosen to delete or replace with different ones!
    Now, if I have decided to deleten an image then I obviously don't want it to be avaliable for viewing!
    How do I go about deleting the links to the old images and making them inacessible? Do I delete them from the media library? And what is going to happen to this single precious comment I have received (it had been left under a image I no longer want accessed...)

  4. right, I fidddled with the pages of my blog, have done some self-exploring and discovered what seems to be the root of the problem. As my site is a design one, I have a number of images on it and, wherever a single post has more than one image and/or gallery inserted then:
    by right clicking any gallery image and choosing 'open link in a new tab/ window' the viewer gets an access to ALL the images I have EVER published under that particular post, even those I have chosen to delete or replace with different ones!
    Now, if I have decided to delete an image then I obviously don't want it to be avaliable for viewing!
    How do I go about deleting the links to the old images and making them inacessible? Will deleting the images from media library do the job? And what is going to happen to this single precious comment I have received (it had been left under an image I no longer want accessed...)

  5. I'll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  6. When you click an image from the gallery you can leave comments to each image. The comment you are referring to has been made to an individual image, that's why it doesn't appear on the post itself.

    by right clicking any gallery image and choosing 'open link in a new tab/ window' the viewer gets an access to ALL the images I have EVER published under that particular post, even those I have chosen to delete or replace with different ones!

    I can't seem to reproduce this issue. Could you send us a screenshot of the page where you're seeing this? You can upload the screenshot to your blog's media library.

  7. Hi!
    Thanks for the answers and please excuse me, I didn't mean to be short I just thought that maybe my query wasn't coming through or something... :)
    When it comes to the issue of deleted/ replaced images being accessible, I have been searching through the forums and fiddling with gallery settings where I changed the 'link to' option from 'attachment page' to 'media file', which seems to have solved the problem of replaced/ unwanted images being accessible by my site's viewers (which is probably why you weren't able to see them either!).
    However, the issue of the comment still remains: as it was made under one of those unwanted/ discarded images (here, to be precise: http://gosiasdrawer.wordpress.com/2012/08/10/japanese-design/japanese-design/#main) I'd like to somehow relink it so it is still visible under the post. Is that at all possible?

  8. oh no!
    been trying to relink the comment myself and, in order to do that, I have decided to get rid of the image it was originally under from my media library but, with deleting the image, the whole attachment page relating to it is now gone!! including the comment! and the comment count in the dashboard is now zero! I didn't realise that deleting one image will wipe out so much...
    please tell me there is a way to restore that image and it's all-important attachment page...!

  9. If you don't see the image listed in your Media Library at https://gosiasdrawer.wordpress.com/wp-admin/upload.php it's deleted and can't be restored, including the comment because that was attached to the image attachment page.

    You can re-upload the image to your post at https://gosiasdrawer.wordpress.com/wp-admin/post.php?post=299&action=edit

  10. it's definitely gone from my media library...
    so there's no bin/ folder you could still retrieve that attachement page then, huh? oh well, a valuable lesson on attachement pages learnt the hard way then...
    :)
    thanks for support and replies though!

    by the way, I still think that there's something up with the functioning of image gallery: if, like me, people are running image based blogs/ sites and they choose to 'link to attachment page' in gallery's settings, they'll end up with having all their images they have ever included in that gallery accessible for viewing... one way round it seems to be to choose 'link to media file' instead of attachment page, but I am wondering if the image accessibility issue is an intended thing or if it's in fact an error...

  11. they'll end up with having all their images they have ever included in that gallery accessible for viewing

    This should not happen. What's the address of the page/post where you see this issue?

  12. I thought it must be some sort of gallery blunder...
    I'm in the process of updating all my posts to eliminate that problem but haven't yet changed gallery here:
    http://gosiasdrawer.wordpress.com/2011/07/28/6/
    if you right click any of the thumbnail gallery images, open it in a new window or tab and navigate through images using 'previous' arrow, you'll eventually get to an image that used to be a part of this particular post, but which I had removed quite a while ago...

  13. Hi there,

    This actually isn't an issue with the gallery. If you click on the gallery to open the carousel, you will only see the images in the gallery.

    If you click to the image's attachment page, you can use the "next" and "previous" arrows to view all of the images attached to the same blog post. This includes images that aren't in the gallery or images that were later removed from the blog post.

    You can find out what post an image is attached to by going to Media > Library in your dashboard. In the "Uploaded to" column next to each image, you'll see the post the image is attached to. If you remove an image from a gallery or blog post and don't want anyone to be able to see it at all anymore, you can delete it from your media library permanently. (That will remove the image, its attachment page, and any comments on the image.)

    Please let me know if you have any questions about that!

  14. Nope, no further questions about that. fiddling with my posts and media libarary trying to eliminate that issue I arrived at similar conclusions actually...
    I guess I'll go and close this topic now, thaks for responses everyone!

Topic Closed

This topic has been closed to new replies.

About this Topic