Need help? Check out our Support site, then


Archive Widgit Annoyance

  1. transparencyofadreamer
    Member

    Hi there fellow bloggers.
    I'm trying to add an archive which just doesn't want to show up.

    I followed the tutorial. Currently I have the widgit in my main sidebar area as the second option under my main links. The showcase sidebar and the 3 footers are empty at this time.

    Checked - http://en.forums.wordpress.com/topic/widgets-not-showing-up-3?replies=9 and followed advice there - no dice. I also searched back 10 pages as well with no other topics that helped.

    I'm looking to have archives just on the main blog itself that can be found at transparencyofadreamer.wordpress.com - I'm not looking to have it on all of my individual pages / posts at this time. Possibly later, but not at this time.

    Current theme - 2011.
    Left side bar chosen and selected.

    Not sure what I'm doing wrong unless I missed a point in the 2011 theme that states Widgits aren't available.

    Any feedback would be a great help! Thanks :)

    The blog I need help with is transparencyofadreamer.wordpress.com.

  2. There is no sidebar on single posts displayed on their own pages in the Twenty Eleven theme. You can choose the default Page template and there will be no sidebar displayed.
    I find these to be very helpful when working with the Twenty Eleven theme.
    http://theme.wordpress.com/themes/twentyeleven/
    http://twentyelevendemo.wordpress.com/
    http://wpbtips.wordpress.com/2011/05/04/workings-of-duster/

  3. transparencyofadreamer
    Member

    Thanks for the links.
    You mentioned there is no sidebar on single posts. I'm not trying to add a widget or sidebar to a single post. I want the archives just on the main page for now. As far as I know I don't have any sidebars active except for when I try to drag and drop the widget in one of the sections - one of those sections says "main sidebar" which currently houses my links and those show fine. Why the widget will not doesn't make sense to me when the links show fine.

    I had dragged and dropped the archives into the section that says main side bar where my links are. Those show up fine. The widgit however does not. No matter where I put it, main sidebar / footers...doesn't matter.

    Maybe I should be just looking for a different theme altogether as it seems I'm too dense to understand why the widgets aren't showing up and I can't identify the issue through the links you provided :(

  4. This is not a theme issue. Make sure the widget is in the "Main Sidebar" area, open it, and click the Visibility tab. What are the three pulldowns set to?

  5. transparencyofadreamer
    Member

    Thanks for the confirmation re: theme issue!
    As per your question -
    * Title filled out.
    * Show post counts is checked.
    * Show if date is monthly archives.

  6. There's your mistake! The visibility options don't control what will or won't show in the widget, they control which pages the widget will or won't show on. When you select "Show if date is monthly archives", you say that the widget will appear on monthly archive pages only. Check for yourself:
    http://transparencyofadreamer.wordpress.com/2013/04/
    To make a widget appear on all pages, you don't tamper with the visibility options at all when you first drag it to Sidebar. Now that you've added the widget, open it, click Visibility, set the second pulldown to "--Select--" (so that nothing is selected), save.

  7. transparencyofadreamer
    Member

    Thank you so very much for giving me the quick walkthrough. Looking at the options I figured that it meant it would show archives in a monthly fashion if I chose "monthly", which is why I chose that as opposed to weekly or whatever. So that's why it didn't make sense why the darn thing wasn't showing up.

    That has been a great help and it's much appreciated. I'll be sure to not make that mistake whenever I choose to add the archives to any other themes I might use in the future!

    Cheers!

  8. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic