Need help? Check out our Support site, then


Askismet Blocking All Comments

  1. lowcountrydigital
    Member

    Askismet is blocking all comments made on my blog. Any idea how I can correct this? Askismet can not be disabled as its a wordpress.com site.

    Thanks!

    The blog I need help with is jubileeprojectsc.wordpress.com.

  2. Are you SURE some of them are not spam?

  3. lowcountrydigital
    Member

    Well, it captured all of my comments including the ones I made while logged in.

  4. lowcountrydigital
    Member

    Is there any way to configure askismet's settings? Or set it to view the comments askismet thinks are spam and give us the ability to over ride that spam designation?

    Thanks!

  5. lowcountrydigital
    Member

    Apparently this is the same problem that was happening back in 2007:

    http://en.forums.wordpress.com/topic/akismet-unable-to-see-caught-spam-messages?replies=27

    Was there any resolution? Thanks!!

  6. Hi there - I don't see any comments on your site, either in your spam queue or elsewhere.

    I see only one test comment in the trash.

    Could you please provide links to a few spammed comments so I can take a look? Thanks.

  7. lowcountrydigital
    Member

    For example:

    This is what I see when logged into my dashboard

    And these are my akismet stats for the same blog

    My discussion settings include:

    • Allow people to post comments on new articles
    • Comment author must fill out name and e-mail (only, not be registered)
    • An administrator must always approve the comment
      Don’t discard spam on old posts

    Any ideas?

  8. lowcountrydigital
    Member

    That's the problem. I can't see any spammed comments except what the akismet stats page tells me. Also, all of the comments that akismet says are from today are me trying to post a comment. Its very strange.

    Thanks for looking into this!

  9. lowcountrydigital
    Member

    In case I wasn't clear, I've posted about 7 comments today and none of them are showing up. Two were even while logged in as me. I am thinking that akismet was capturing them but maybe I'm wrong. I feel like I'm going a bit spam crazy :)

  10. lowcountrydigital
    Member

    Ok, this gets weirder and weirder.

    Here is a screenshot of a post I just created and successfully commented on - no problem here.

    Here is a screenshot of a previous post (that another user made) that cannot be commented on.

    The entire entry format is different, but her post and my post had the same settings. Is this a permissions issue maybe and has nothing to do with akismet, since I was able to comment successfully on a post I made?

    Thanks again!

  11. lowcountrydigital
    Member

    Also, though commenting has always been enabled for posts, most posts don't seem to even allow comments. Which is odd. Apparently only the post I just made, that you just commented on, is allowing comments.

  12. lowcountrydigital
    Member

    Correction, only the posts I've made can be commented on. The user whose permissions are set to Author can not create posts that have commenting. Is that a setting that I'm unaware of?

    Thanks again.

  13. The entire entry format is different, but her post and my post had the same settings.

    For some reason, you've added contact forms to the bottom of some of your posts, so that's the form you're seeing on certain posts, like this one:

    https://jubileeprojectsc.wordpress.com/wp-admin/post.php?post=105&action=edit

    See the contact-form shortcode in your post?

    Since information entered into the contact form is not a comment, it won't appear in your comments list.

    You've also unchecked the "allow comments" box in the Discussion settings on some pages, like the one above, which is why the comment form is not displaying. See the settings here:

    http://cl.ly/image/171K0K451g2v

  14. lowcountrydigital
    Member

    No idea how she posted that shortcode.... I'll get that out of there and ask her about it.

    Where is that "allow comments" setting screenshot from?
    I was under settings-->Discussion but didn't see it. Nor is it on my edit a post page.

    Thanks again.

  15. lowcountrydigital
    Member

    Wait a minute. Found it. The Discussion settings are only under Quick Edit, is that correct?

  16. lowcountrydigital
    Member

    Nope, wait a wait a minute. The setting was disabled in my screen settings. I'm a total idiot.

    Thank you again for all of your help. I've adjusted the tags on this post so other people have mental breakdowns such as myself can troubleshoot this relatively easy problem without bothering you.

    Sorry again for the lack of brain cells. :)

  17. Where is that "allow comments" setting screenshot from?

    The screenshot is from this page:

    https://jubileeprojectsc.wordpress.com/wp-admin/post.php?post=105&action=edit

    If you don't see the Discussion settings, you can turn it on by clicking the Screen Options button at the top right of the page, and then checking off the Discussion checkbox:

    http://cl.ly/image/1V3z250F1E1W

  18. Look at Dashboard >> Feedbacks and see what's there.

    I found some stuff there when I used a Contact Form.

  19. lowcountrydigital
    Member

    Nope, wait a wait a minute. The setting was disabled in my screen settings. I'm a total idiot.

    (see my last comment above) :)

    Thanks again everyone!

  20. Glad this seems to have been sorted out. If you need anything else feel free to start a new thread.

Topic Closed

This topic has been closed to new replies.

About this Topic