Need help? Check out our Support site, then


Audio files inserted into posts: media title does not display

  1. I've had a WP site for nearly 3 years, never had a problem inserting audio files into posts. Suddenly, instead of displaying the media title, e.g. 'Song', as it has done all this time, it displays the full url - no media title. The full url is of no use to me, and I don't understand why the function has suddenly changed. The only workaround is laborious, copying and pasting the url into the 'use url' function, which forces it to display the title. Any help much appreciated!

    The blog I need help with is marlboroughcommunitychoir.org.

  2. I should have also said that I've tried every option on the Attachment Settings menu, and it makes no difference. I've tried both IE and Firefox and get the same result.

  3. That's weird. Presumably your space upgrade has not expired, right?
    Please check here Store > My Upgrades to confirm.

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache:

    http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/ and also post any error reports you get.

  4. Thank you. I am using Firefox 20. The site has not worked properly in IE for a long time (can't upload files). I have followed the instructions except the last, as I can't find the Users tab to change to https. But following steps 1-3 has not fixed the problem. My upgrade has not expired. I can upload files to the media library. The problem is inserting them into posts. So instead of see 'Song' on the page, I get 'long url for song' appearing. Any other suggestions?

  5. I get the same problem persisting in IE9 after following steps 1-3.

  6. That's with both 64 and 32-bit IE9.

  7. I'll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  8. Thank you very much for your help. I look forward to hearing from them.

  9. As this is a choir website, I upload up to 30 audio files at a time, so it needs to work like it did before! No idea why it has changed.

  10. Would you please give us a link to the post or page displaying the problem?

  11. Here you go, I've added a file at the top of the page to show how the display is wrong http://marlboroughcommunitychoir.org/members-area/. The password is 'heaven'.
    The attachment setting for the media is 'none'.
    You can see on the rest of the page how it used to work. Now, when the page renders, you get an MP3 player with no title. Changing the attachment settings doesn't make the title display.
    Apologies for the delay in replying. Although I'm signed up to follow this thread, I received no notification of your post.
    Thanks
    Vanessa

  12. Oh, I see what you mean. We're aware of the issue.

    For now, you'll need to get the file URL from the Media section of your blog's Dashboard, then create a link to it: http://en.support.wordpress.com/links/

  13. Thanks for confirming. Any idea of a timescale for it to be resolved? I upload a lot of files at a time, and cutting and pasting a url for each is really laborious.

  14. You're welcome!

    We don't have an ETA for the fix yet.

  15. How can I find out when it is fixed?

  16. I'll leave a reply here.

  17. Thank you.

  18. Is there any news on this? I've got a lot of files to upload, which is going to be really tedious if it's not fixed.
    Thanks
    Vanessa

  19. Hello, is anyone there? If you don't plan on fixing this problem anytime soon, I'd like a refund of my upgrade fee until it is fixed. I'm sure that other people who upload media files will agree that it's not acceptable.
    Vanessa

  20. My apologies for the delay in getting back to you.

    Another member of Staff has requested that this be added back to WordPress.com (because of many requests from users) as it is a known issue as @macmanx mentioned above, but as of today there's no ETA as to when this will be updated. I'm sorry I don't have more information for you.

    Since you purchased the Space Upgrade back in October 2012, I'm unable to process a refund for you as it is well outside the 30-day refund window. However, I decided to add a $5 credit to your account that you can use towards any upgrade renewals or new WordPress.com Store purchases. I hope that helps!

    I will respond here once I have anything new to share with you. Thanks for your patience while we get this sorted out.

    In the meantime, let me know if I can help with anything else.

  21. Thanks for the credit, I appreciate it. However, if this doesn't get sorted out soon, I think you'll need to re-think your refund policy. I notice you've added a new 'quick post' for the home page which invites us to add media, with the same problem again. I had to upload 8 files today, it took 20 mins. This isn't workable. I'm seriously thinking of moving the whole site, which would be a lot of hassle, but worth it to get something that functions.

  22. I understand your concerns, unfortunately I don't have anything new to report at this time. While we would hate to see you go, moving to a self-hosted WordPress.org site is an option for you to explore. You would need to pay for hosting, but you would have more flexibility to add plugins and other such things that would make downloading your audio files easier for your visitors.

    Also, with the Jetpack plugin, you get a lot of the features you enjoy on WordPress.com and we would be able to transfer any WordPress.com followers and email subscribers to your new self-hosted site. Here's more information on Jetpack: http://jetpack.me/

    You also can keep your domain at WordPress.com and simply change the domain nameservers to point to your new host, or you can transfer the domain to a new registrar.

    If you have any questions on this process, I'll be happy to answer them for you. Again, I'm sorry I don't have anything new to report, but I hope this helps.

  23. I have an update!

    We just released an update that I believe may have fixed this problem. Can you try to add audio files to your post again like you used to and let me know if you run into any problems?

    I'll wait to hear back from you how it goes. Thanks again for being patient.

  24. Hello - well I can now upload Word files properly, but it still doesn't work for audio files. I tried several different ones, both those already uploaded and those not uploaded before. Same result. :-(
    At least it's a partial improvement!

  25. Ok - thank you for the update. I'm going to go back to our developers to let them know you're still having problems adding audio files.

    One thing that I would like you to do is to create a new page where you can upload audio files so we can see the behavior that is happening. Don't publish this page, just save it as a draft and call it "Audio Test" or something similar. Staff will have access to your site's dashboard so we will be able to look at it in its draft form.

    Also, if you can take some screenshots of your audio uploading/linking process (and where it goes wrong), that would be very helpful. Just add the screenshots to your site's Media Gallery and we can take a look. This page has some helpful tips for taking screenshots: http://en.support.wordpress.com/make-a-screenshot/

    Let me know if you have any questions! Otherwise I'll wait to hear back from you regarding the test page.

    Thank you again for your patience while we try to sort this out.

  26. Thanks, I'm really glad that something is happening. I've created the page 'Audio Test' and loaded 3 files: 1 Word (loaded properly) and 3 audio (not loaded properly). Only the title of the content should appear, not the long url. If you preview the page, you can see that the Word file is rendered properly but the audio files still show the long urls. I haven't added screen shots because that's the whole process. I hope this helps, let me know if you need me to do anything else.

  27. I will be going into look at this page - it shows you as currently editing it and I will need to take over editing to see the post code.

    Let me know if you have any questions!

  28. Thank you for setting up that test page.

    One question: before, were you able to go into "Add Media" and upload and insert the file links and it would use the file title (e.g. "Bambelela ALL") rather than the file name (e.g. "http://marlboroughcommunitychoir.files.wordpress.com/2010/09/bambelela-all.mp3"?

    If you can clarify that, it would be a huge help. Thank you!

  29. Yes. Something changed about 2 months ago. Before that, I could just click 'insert into post' and the content file title would appear. But then it stopped working. The long file title would appear on the editing screen, and then be rendered on the page as a blank audio player. Now when you preview the page, you don't see the blank player, you see the long file url.

  30. Great - thank you for clarifying.

    I'm going to have one of our developers take a look and I'll get back to you once I have more information.

    Thanks again for your patience. Have a good weekend!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.