Need help? Check out our Support site, then


Background shading changed on my 2011 theme

  1. I don't know what happened - I didn't change anything. How can I get back to the original 2011 theme color (white background)?

    The blog I need help with is expateducator.com.

  2. The site linked to your username is wearing Pilcrow. Please give us a link to the site you are talking about.

  3. I just changed it - I couldn't stand the gray. Any idea what happened?

  4. Just changed it back so you could see.

  5. I think this may be caused by an open HTML tag in your latest post.

    Go to settings > writing and select "WordPress should correct invalidly nested XHTML automatically" and then click "save changes."

    Open your latest post, open it in the editor, switch from the visual tab to the HTML tab (waiting for the page to refresh) and then switch back to the visual tag (again waiting for it to refresh), and then click "update post." Check your blog and if it is back to normal. I think it will be.

  6. @Rich: yes it will (she's got a stray div tag in the latest post).

  7. @Panos, yes I saw that in the W3C validation report, but didn't track it down other than to click on a couple posts to see which one was the problem.

    2011 reacts differently to a stray or missing tag than other themes.

  8. And if you ever manage to understand why WP keeps the default for this option to off instead of on, please enlighten me too.

  9. Yeah, that has always puzzled me as well.

  10. Wow. I don't know html but have played with it a bit on this blog. the extra </div> tag on the end caused all those problems?

    You guys totally rock.

    Thanks,
    Janet

  11. You are welcome.

    The change I mentioned at settings > writing will keep that from happening in the future.

  12. I can't seem to find that in my settings. I looked tho.

    I knew about the evil divs for spacing after bullet points. I didn't realize the trouble they could cause for other formatting.

    What is a div anyway? Is it short for "divide"?

  13. Please go here again and look hard at that page that thesacredpath directed you to. What you are looking for is this:
    Go to Settings > Writing and select “ ___ WordPress should correct invalidly nested XHTML automatically” and then scroll down and click “Save Changes.”

    If you have been copying and pasting text from elsewhere without using either icon 5 or icon 6 in Row 2 of the visual editor, please see here so you know how to do this correctly in the future. http://en.support.wordpress.com/visual-editor/#pasting-text

  14. "div" stands for "division". It's an HTML tag that marks sections. Practically all HTML tags must be paired: opening tag - closing tag (same tag with a slash before it). If you have a stray opening tag you say "from here to infinity"; if you have a stray closing tag, you say "from nowhere up to here": in both cases your page will get messed up.

  15. Awesome to know. I found and ticked the autocorrect button.

    I also seem to have messed up the mobile-devide version code. The Onswipe iPad Settings is still activated.

    Any ideas for that?.

  16. Nevermind. It works.

Topic Closed

This topic has been closed to new replies.

About this Topic