Need help? Check out our Support site, then


Big Brother Theme - Social Facebook Plugin

  1. I am having an issue getting the Facebook Plugin to work from Widgets and also custom social plug-in in the footer. When I add a "Facebook Like Box" from the widgets menu. It states "The Like box only works with Facebook Pages". My FB is a "Page", but does not have "/page/" in the URL. Is this the issue?

    I tested 2 different FB sites:

    It DOES NOT WORK with this page: https://www.facebook.com/Isd88voteyes

    It WORKS with this page:
    https://www.facebook.com/pages/Friends-of-ISD-88/287241057981896

    They are both FB "PAGES", but notice the URL of the Friends page HAS the word "pages" in it.
    NOTE: it appears to work when I preview the page, but when viewing live it does not show up. The box is empty.

    Please advise.

    The blog I need help with is isd88voteyes.org.

  2. I'll tag this thread for a Staff follow-up. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  3. Hi there,

    I wasn't able to view the Facebook page at this link: https://www.facebook.com/Isd88voteyes

    Can you double-check to make sure that's a public, published page?

  4. Hi rachelmcr,
    Yes, the Facebook page listed above is a public published page. It's very strange, I am an admin for 2 Facebook pages, I do not see anything different in the settings for the 2 pages I manage with the exception that the one that doesn't work has a custom facebook web address.
    This is the other site FB site I manage that works:
    https://www.facebook.com/pages/Friends-of-ISD-88/287241057981896

  5. Hi there,

    When I try to visit the link https://www.facebook.com/Isd88voteyes I am redirected to Facebook's home page at https://www.facebook.com/ instead. (You can also check this by logging out of Facebook and then visiting your Facebook page at that link.) That's a sign that perhaps your page isn't published yet, or it isn't fully public.

    You may want to check the Facebook page's visibility settings, described here:

    https://www.facebook.com/help/184605634921611

    If those settings look ok, can you make a screenshot of that Facebook page? That will help me investigate this further. You can upload screenshots to your Media Library under Media > Add New in your dashboard, or you can use an online service like Snaggy.

  6. Hi rachelmcr,
    From what I can tell, our Facebook page is published. I tried logging out of FB also, and you're correct...for some reason the page doesn't come up. I can't tell what's going on. I've compared this FB page with another I admin and the only difference is the URL string.

    If you could check out my FB settings, I've uploaded them to my Media Library for the site. I've labeled them Facebook_Settings and Facebook_Page_Info.
    Thank you!

  7. Hi there,

    Thanks for sharing those settings. I noticed that in the General settings, under Country Restrictions, the page is set to only be shown to people in the United States. Could you try removing that country restriction to see if it makes a difference?

  8. YES, that did it! The feed works now after I changed the page so it's visible to everyone, not just United States. I saw that setting before, but didn't think it would make a difference.

    BIG THANKS!!!

  9. You're welcome! I'm glad we found the right setting to make it work. :)

Topic Closed

This topic has been closed to new replies.

About this Topic