Need help? Check out our Support site, then


Blockquote font style on Twenty Ten theme

  1. leftbrainedwriter
    Member

    I am trying to modify the font style of the blockquote on Twenty Ten. The default seems to be italics, which I can un-italicize no problem with a simple blockquote paragraph or an un-ordered list. With an ordered list, however, when I try to un-italicize, the numbers remain in italics. I tried to change blockquote font-style to normal, but that just made it impossible to have anything italicized within a blockquote, and sometimes I want to italicize things. Any suggestions?

    The blog I need help with is occupiedandpreoccupied.wordpress.com.

  2. If you set the blockquote to normal text in the CSS, and then you make something inside of a blockquote italics within a post or page when creating it, it will be italic. The formatting you set with a post or page will always override the CSS. This will set blockquotes back to normal text.

    blockquote {
    font-style: normal;
    }
  3. leftbrainedwriter
    Member

    Hi, thanks for the reply.

    I tried what you suggested, and all blockquotes ended up un-italicized; none of the italics formatting within any of the posts overrode the CSS.

    I ended up putting it back the way it was, but as you can see in today's post (http://occupiedandpreoccupied.wordpress.com/2012/08/03/places-that-dont-exist-anymore/), the numbers in the ordered list midway down are in italics even though the rest of the list is not.

    Do you have any other ideas? I am new to CSS and trying to learn.

  4. I've tried this on my test blog and if I add the CSS and then in a blockquote highlight some text and make it italic, that text I set to italic in the post editor shows as italic on the blog, so I'm not sure what you are doing.

    You can't use CSS, or shouldn't use it to change just select blockquotes. CSS is meant for overall changes.

    Perhaps let's start with you explaining again exactly what it is you want to accomplish.

  5. Also, why on earth are you enclosing a list in blockquote tags? A bq is used for quotations only.

  6. leftbrainedwriter
    Member

    @justpi, I'm enclosing a list in blockquote tags because I wanted it indented and set apart from the main body of the text. Since I can't just use the Tab button like in Word, this is my only option.

    @thescaredpath: Okay, here's what happened: I typed up my post, and there were certain parts of it I wanted to have indented as a blockquote. Two of these section were normal paragraphs, and one was an ordered list.

    I highlighted each those sections and clicked the blockquote button. All three sections converted themselves to italics upon doing so (this is within the theme's CSS). But I didn't want the ordered list to be in italics, so I highlighted the entire thing and un-italicized it. But only text part of the list un-italicized. The list number (1., 2., 3., etc.) remained in italics.

    When I tried the CSS change you recommended, it un-italicized EVERY blockquote. It did solve the problem with the ordered list, but created a new one with the blockquotes I wanted in italics. Even though it showed the text being italicized in the post editor, once I actually previewed it, it showed as plain text.

    All I want to know is if it's possible to have the ENTIRE list not be in italics when using blockquote. Maybe it's not with this particular theme (I had no problems with this when I was using the Clean Home theme).

    I apologize if I didn't explain my question properly before and appreciate your having taken the time to answer me.

  7. No that's not your only option! As I said, bqs are used for quotations, not for styling anything else.

    If you want all your lists indented the way bqs are, add this in your CSS editor:

    ul, ol {
    padding: 0 3em;
    }

    If you want them indented occasionally only, turn the opening ol tag to this in the Text editor:
    <ol style="padding:0 3em;">

  8. leftbrainedwriter
    Member

    @justpi
    >No that's not your only option!
    Thanks - I had no idea! I'm still very new to this.

    So, I tried making the ol style change you suggested the Text Editor. What happened was it indented the list (success!) and the list was un-italicized (success!), but instead of regular numbers (1, 2, 3, etc.), the list was numbered with Roman numerals (i, ii, iii, etc.), which isn't what I wanted.

    I see that this bit of code works like in Word where, each time you indent and ordered list, it's treated as a new list level and uses a different numbering system (e.g. level 1 = regular numbers, level 2 = Roman numbers, level 3 = capital letters, level 4 = lowercase letters, etc.).

    Is there a way to indent the entire list without changing its level so I can keep the regular numbers?

    I'm sorry is this is too nitpicky. I'm just trying to learn.

  9. What I suggested does not result in what you're reporting: you probably tried something else as well and messed things up. Check the complete list code in the Text editor - it should be like this:

    <ol style="padding: 0 3em;">
    	<li>LIST ITEM ONE</li>
    	<li>LIST ITEM TWO</li>
    	ETC
    </ol>
  10. leftbrainedwriter
    Member

    @justpi, yes, you're right, it was my bad: I had an extra

      code in there. Doing what you suggested properly produces the desired results. (And thanks to my mistake the first time, I've now learned two things.)

      Thanks a lot for your help. I really appreciate you taking the time to reply.

  11. leftbrainedwriter
    Member

    Sorry, I forgot these text boxes support code. A visual example of what I learned.

    Thanks again.

  12. You're welcome.
    To display code correctly here, you need to enclose it in backticks (see the note on "Allowed markup").

Topic Closed

This topic has been closed to new replies.

About this Topic