Need help? Check out our Support site, then


Blog entry won't accept blank lines

  1. Hi. I notice that when I post a blog entry, if I try to put an extra blank line between one block of text an another, or at the beginning and end of my blog entry (to provide some space around the text in order to isolate it in the reader's eye), the result is that it defaults to a single line-break. I'm using the 'visual' tab because I am not html-literate. Does anyone have any tip for inserting spaces?

    The blog I need help with is kvennarad.wordpress.com.

  2. When you say it "defaults to a single line-break" do you mean no blank line between paragraphs, or just one blank line?

  3. I could best illustrate by example. If you look at the poem in this blog entry: http://kvennarad.wordpress.com/2011/05/13/upon-the-sand/ you will see, apart from the fact that the default line spacing is something like 1.5, that there is no space between lines 8 and 9 of the poem. In my original draft there is a line's space between them. The automatic formatting here has ignored that.

  4. I'm wondering the same thing.

    I tried inserting spaces after my post's 'headline', but to no avail. I also tried inserting
    , but nothing happened.

  5. @rainbowtiger, your site is private, so we cannot see it. If we cannot see it I'm afraid we cannot help other than to offer these very generic three things.

    1. To get standard line spacing on paragraphs (blank line between paragraphs) select all the text in the post, click on the "format" pulldown at the left end of the lower row of icons and select paragraph.
    2. If you want a standard paragraph break, at the end of a paragraph, press return/enter.
    3. If you want no blank line, hold down shift and then press return/enter.

  6. @ thesacredpath

    I'm noting what you said to rainbowtiger, but I don't think that covers my basic problem. I post mainly poetry, which means that the end of each line is the end of a paragraph in effect. My poems sometimes have stanzas; in order to mark a stanza it is necessary to have an EXTRA line's space. I have tried going into the html window and inserting "

    " (at the suggestion of a friend) but that has no effect. I have tried googling 'html line break" (or some such) and have tried each method which suggested itself, all to no avail. I am beginning to think that the problem may be inherent in the template I am using.

  7. Oh... the html command actually WORKED in the above answer, and I got a space!

    Just to let you know that within the quotes above I put the characters < b r > twice. LOL

  8. In theory, and according to strict HTML standards, the br cannot be used twice in a row as that would be the same as a paragraph break (blank line inbetween). WordPress is pretty strict on following standards.

    If you ever need extra space between paragraphs (more than the one line), do this in the paragraph above:

    <p style="margin-bottom: 25px;">All the paragraph text here</p>

    You can adjust the 25px value as you see fit. I just put that in as a placeholder.

  9. One other thing, wordpress is now declaring an HTML5 doctype for all HTML pages here, so you need to use the following self-closing version as a break.

    br />

    Note the space between the "r" and the "/" .

  10. Well and then I mess up the code.

    <br />

  11. A blank line in between is precisely what I want, though, and yet it's precisely what I can't get.

  12. Let me explain better. Imagine two stanzas of a poem thus:

    poem words poem words
    poem words poem words
    poem words poem words.

    poem words poem words
    poem words poem words
    poem words poem words.

    I type that in, using the visual window, and hit enter twice between the stanzas (or I go into html and write some code for inserting an extra line). What comes out is a solid block thus:

    poem words poem words
    poem words poem words
    poem words poem words.
    poem words poem words
    poem words poem words
    poem words poem words.

    What do I have to do to divide the two stanzas?

  13. Thank you Sacred.

    The 'P Style 25px' was exactly what I needed.

  14. @kvennarad
    Just in case you have not located it, the support documentation on formatting poetry is here. http://en.support.wordpress.com/writing-and-formatting-poetry/

  15. @ Timethief

    Ah! Thank you. I shall check that out. You're right, I hadn't realised that those instructions existed.

    M

  16. @kvennarad
    You're welcome. :)

  17. @ Timethief

    I have just been experimenting, and I have managed to separate the two stanzas of my poem here: http://kvennarad.wordpress.com/page/2/

    However, in the instructions I read:
    "You can add as many line breaks as you want; the Visual Editor will never ignore them. Each time you hit Shift+Return, you’ll get an extra empty line..."

    To which I can only add 'Oh no you won't!" For me it did anything but. The first time I tried to put two 'empty lines between the paragraph of text at the top of the blog entry and the first line of the poem I got nothing but a standard paragraph break. So I tried again and again in case I had mis-keyed. Try as I might, I never got more than a single-line paragraph break.

    I haven't given up, however, I'm going to keep trying...

  18. *sigh... nothing doing, either using shft+enter or using the html command
    . Never more than a single blank line.

  19. @ Anybody

    When the instructions refer to the html code
    does that mean that code is as typed, i.e. with a space between the 'r' and the '/'?

  20. be careful with the visual editor; if you switch between visual and html it will lose some of your formatting. i recommend staying in the html editor.

    the "br" code ("br /" is how it should really go) is a soft line break. the "p" and "/p" codes are hard line breaks.

    to get multiple blank lines, i find i have to put a non-breaking space in. " " (the & and ; are part of the code, but it does NOT use angle brackets.)

    to get a single line between paragraphs, hit ENTER at the end of the paragraph, then ENTER again (blank line) and start the next paragarph.

    to get two lines between paragraphs, do that, then type the " " and hit ENTER again. (if you are using div style indenting, you also need to hit ENTER again to force a line break after the blank space.)

    to get a big break between paragraphs, i use "p" and "/p" before an "&nbsp".

    all in all, i really wish wordpress would create an actually WYSIWYG editor that would preserve spacing and blank lines.

    now i'll try to post the code i use as the basis for my blog posts; which contains the blank line breaks.

    <br /> <div style="text-indent:25px;"><hr /><br />  <br /> <p> </p><br /> </div><hr /><br />

    when writing my post, it looks like this:

    <br /> <div style="text-indent:25px;"><hr /><br />  </p> <p>Blog Text: An extra blank line after the " " so this automatically indents. (that's the indenting on the div style, above.)</p> <p>A blank line between paragraphs to make this paragraph auto-indent. If there is not a blank line, the paragraph will NOT indent.</p> <p><p> </p></p> <p>The P's and NBSP's create a bigger jump (i think it looks like 3 lines when published) between lines.</p> <p></div><hr /><br />

    Note: every where there is a new line, there is technically a "br" code. i just don't bother typing that in, because the editor does that for you.

    And yes, when using what used to be single tags (that had no "/" versions in the old days), you now type the regular tag, a space, then the "/" inside the closing angle bracket.
    (like my horizontal rules in the example above.)

  21. ::sigh:: well crud, it ate my " "s inside the code bits. and there's no EDIT comment option?

    please ignore the examples above, since they are screwed up. please look at my blog, on the bottom of the left column, because that's where i store my new post code. (luckily, i haven't made a blank post template yet, for the new copy post feature. :X )

    http://bloodsongtermagant.wordpress.com/

    sorry about that.

    the basic gist is, if you want more than one blank line in a row, you have to put a non-breaking space on them. and hitting spacebar doesn't work, if i recall correctly :X

  22. Non-breaking spaces, empty paragraphs or divs and the like are stripped out if you switch to visual. See here for more stable solutions:
    http://wpbtips.wordpress.com/2009/06/10/formatting-text-pt-1/

Topic Closed

This topic has been closed to new replies.

About this Topic