Need help? Check out our Support site, then


Blog loads too slow

  1. Hello.

    I've been having this problem for quite some time (months I guess), although used to think it was caused by the settings of my browser. Last night I tried to open my blog from a friend's PC and loading time was similarly long (around 10 seconds). This only concerns the initial load - if I close the blog tab and try to open the blog again, this time it loads in 2-3 seconds.
    What might be the reason for this, and how can I fix it?

    Thanks in advance.

    The blog I need help with is tornike.wordpress.com.

  2. danielfarrellnzl
    Member

    That sounds about standard... The first time it loads, it needs to bring up all the resources on the page. When you load it the following times, it saves those resources into the cache, so it will be much quicker.

  3. Yep I'm familiar with that mechanism, although 10 seconds looks too much for me.

    Thanks for the reply.

  4. P.S. 10 seconds is the time before the blog and its contents start to appear. During those 10 secs there's only blank page and loading animation I see.

  5. danielfarrellnzl
    Member

    To be honest, unless you've added something that's of significant size to your homepage, I don't think it's something at server side. It would either be your ISP or something on your computer. Obviously the latter can be ruled out, as you said you've seen it on other computers.

  6. OK, I have a SoundCloud track embedded, as well as quite a few RSS feeds, so possibly those could be the reason. Thanks for the information.

  7. danielfarrellnzl
    Member

    Yeah, I would suggest that would do it. Your browser is having to go to not only the wordpress.com server, but also the soundcloud server, as well as any server hosting the RSS feeds. That takes a little while.

    Glad to be of help :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags