Need help? Check out our Support site, then


Blog On Another Page

  1. Hi! I made a static page, or in other words, I moved the posts from my home page to another page. I can't figure out how to post on my new post page now. If I click new post and I make it, it will just delete everything on the home page and put it there. I don't want it on my home page though. Anyone have any ideas on how to put it on my new post page?

    The blog I need help with is alilovesloki.wordpress.com.

  2. Hi. You appear to have set a static page as a front page and "Posts" as your posts page. So any new posts should appear here...
    http://alilovesloki.wordpress.com/posts/
    ...as well as through their individual URLs as usual. Have you actually tried it?

  3. I don't really know.... my uncle knows more about it than I do.

  4. Wait, ya! I did try it and it didn't work... sadly. I tried multiple advice from everywhere.

  5. Okay, let me just ask you real quick:
    On the dashboard, go to settings>reading
    Is the choice "A static page" selected?
    If so, the Front Page should have "Home" in the dropdown, and the posts page should have "Posts".
    If thats not it looks like then I'm clueless. O.o

  6. Ya, someone else actually told me to do that too, but I already had that setting saved... sorry :(

  7. Does anyone know why it's going on the front page instead of my posts page???

  8. Hi. If you can't wait for a volunteer to look further into your problem, or if you are not satisfied with the answers you had so far, maybe it's time for you to contact staff directly:
    http://en.support.wordpress.com/contact/

Topic Closed

This topic has been closed to new replies.

About this Topic