Need help? Check out our Support site, then


Blog pages show at most missing from Settings

  1. veronicabenzing
    Member

    Hello! I just noticed that my blog no longer displays only 1 post on the main page. I checked the Settings | Reading section and noticed that the "Blog pages show at most" option is missing. It was there before, but now it is gone. Also, my blog now displays every post that I have written since 2009 on the main page... yikes!! I did not make any recent changes to my blog. I have had the blog since 2009 and it has been working perfectly until now. Any ideas?? Thanks a million in advance!

    The blog I need help with is veronicabenzing.wordpress.com.

  2. Hello there,
    Staff have introduced “infinite scroll” to some themes and will be implementing it on all themes that have a suitable structure for infinite scroll. This is a site wide change.

    If you have a theme with footer widgets you can use a workaround to regain control over how many posts are displayed on the front page of your blog. If you have a theme with footer widgets all you need to do is install an empty text widget into any footer area for widgets. When you do that there will be an option displayed on this pgae > Settings > Reading to disable infinite scroll. Once you have done that your number of posts set on that same Reading page will prevail.
    http://en.forums.wordpress.com/topic/to-infinity?replies=137

    For some other theme possibilities see here > http://en.forums.wordpress.com/topic/of-posts-displayed-on-front-page?replies=21#post-842402

    For updates on which themes have infinite scroll see here > http://theme.wordpress.com/themes/features/infinite-scroll/

    P.S. Will you please always provide an active link starting with http:// when posting to the forums? We Voluntters cannot seethe link you enter when you create a thread, only Staff and at support bot can see that.

  3. veronicabenzing
    Member

    Thank you so much for the reply and suggestions!! This really stinks that WP just introduced this feature without asking the users. The theme that I am using does not contain a footer, so I will not be able to fix this. I really do not want to change my theme either, since I like it and picked it for a reason. But I guess that does not matter anyway since it is a site wide change. I realize that there are a few themes that contain footers (I actually just started another blog that does contain a footer), so I will have to give it some thought about the theme change on my main blog.

    I liked this article that you provided to another user: http://wpbtips.wordpress.com/2012/02/25/there-we-go-again/

    I am baffled that the founder actually said that if we don't like this feature, we should use another blog site. Does he not care about his customers?? Very interesting.

    I apologize for not providing a link to my blog. This was my first time posting in this forum and I was not sure what to expect as far as replies. I will provide it in the future.

    Thank you so much again!

    (http://veronicabenzing.wordpress.com)
    (http://sweetpeabenzing.wordpress.com)

  4. veronicabenzing
    Member

    Sorry! I just realized that it was not you who provided the link that I included in my previous message. In any case, it was a good article. :)

  5. The only thing you can do to get rid of infinite scrolling is create a static intro page in Pages > Add New, set that page as your front in Settings > Reading, and rely on the Recent Posts and the Categories widgets for navigation.

    (And as the author of the post you included, I can tell you that no he doesn't.)

  6. veronicabenzing
    Member

    Oh, that might be a good workaround. I'll try that. Thanks so much justpi!!

Topic Closed

This topic has been closed to new replies.

About this Topic