Need help? Check out our Support site, then


Blog posts appearing on "blog" page but with incorrect permalink

  1. My website is http://www.naomigoodlet.com and is still under construction.

    Under the "reading" settings, using the static page option I chose to have my posts directed to my "blog" page which has been working fine. When I click on the "blog" page I am able to see a list of my recent posts....

    BUT the permalink for EVERY post is http://naomigoodlet.com/about
    Is there any way I can change this??? I am not able to edit it in the edit post section.

    It is preventing me from receiving comments and being able to link directly to individual posts which I would like to do.

    I'm guessing that I've done this by accident as I was setting up the site but either way, I'd love some ideas about how to fix this! I use the prana theme.

    Thank in advance. Naomi :)

  2. You did not specify a blog address or reason for posting when you created this topic.

    This support forum is for blogs hosted at WordPress.com. If your question is about a self-hosted WordPress blog then you'll find help at the WordPress.org forums.

    If you don't understand the difference between WordPress.com and WordPress.org, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It'll help people to answer your question.

    This is an automated message.

Topic Closed

This topic has been closed to new replies.

About this Topic