Need help? Check out our Support site, then


Blog posts not being automatically displayed on Facebook

  1. My blog post is not getting automatically updated on Facebook even though I have enabled the Facebook button in my Settings options and it shows as Connected.

    I have also tried ticking the Facebook option under publicise (when I have finished writing the post and am about to publish it) but inspite of doing so, when I go back and check it later, the FB buttons are once again unticked.

    Please help as FB is the only way I publicise my blog!
    Blog url: http://memoriesofchocolate.wordpress.com/

  2. 1. Try flushing your FB cache but disconnect from FB first http://umairj.com/146/how-to-clear-facebook-shares-cache/
    2. Try the full reconnect procedure again detailed at http://en.support.wordpress.com/publicize/#reconnecting-facebook including step 3 (removing the FB app), which is probably the most important step.
    3. See also publicize troubleshooting http://en.support.wordpress.com/publicize/#troubleshooting

    Please help as FB is the only way I publicise my blog!

    No. RSS Graffiti periodically checks the RSS/Atom feeds that you specify and posts any new entries it finds to the Facebook Walls that you specify. http://www.facebook.com/RSS.Graffiti

    You can get any feed written on any wall (Facebook Profiles, Fan Pages, Groups, Events and Application Profile Pages). In fact, multiple feeds to multiple walls. You choose the combination.

  3. Tried the first option and it worked! Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic