Need help? Check out our Support site, then


Blogstomp Uploader won't connect.

  1. krismillerphoto
    Member

    I am attempting to use the uploader BlogStomp and it is unable to connect. I believe this may be due to a "multisite" issue but I do not have a multisite, or at least don't want to. How can I fix this issue?
    Blog url: http://krismillerphoto.wordpress.com/

  2. I don't know what BlogStomp is or what you are trying to do. Would you care to expand?

    See also Media Library ยป Multi-file vs. Browser Uploader http://en.support.wordpress.com/media/uploader/

  3. BTW if this is about embedding iframes then know that they cannot be used on WordPress.com blogs. The software will strip the code out to preserve security. http://en.support.wordpress.com/code/

  4. krismillerphoto
    Member

    Blogstomp is an app that is supposed to connect with multiple blogs and allowing posting directly from the App itself. Its to help with the tedious picture uploading. Multisite won't allow for it, but far as I can tell, I only have one site. So it shouldn't be an issue.

  5. Hi again,
    I flagged this thread for Staff assistance.

  6. It's possible that it works with WordPress.org blogs, not WordPress.com blogs.

    Are they asking for an XML-RPC URL?

  7. krismillerphoto
    Member

    They are asking for the XML-RPC box to be checked, which I could not find. Is that the difference? .org vs .com?

  8. It's already enabled by default.

    Make sure that you're giving them the correct XML-RPC URL: http://krismillerphoto.wordpress.com/xmlrpc.php

    http://en.support.wordpress.com/xml-rpc/

  9. krismillerphoto
    Member

    I will give that a try, but one the first go it crashed the App. So I will forward that note to the App help center as well.

  10. Excellent, please let us know how it goes!

  11. krismillerphoto
    Member

    Unfortunately that particular web address now gives an exception error and crashes the app. Its a really good App for doing large amounts of photo upload and arranging. Hope I can get it working!

  12. Have you contacted them about this?

  13. krismillerphoto
    Member

    I have, and am waiting to hear back now. Worse case scenario I am going to ask for a refund.

  14. Excellent, please let us know how it goes!

  15. Hiya - I'm Danny one of the developers of BlogStomp. We've updated BlogStomp to allow you to test your connection with your WordPress blog.

    The problem is only with wordpress.com blogs. The strangest thing is the same code (to test the blog setup), will work in one moment and not the next.

    @Macmanx - Is there a possibility that wordpress is sometimes rejecting our request? Literally without changing any settings our 'test connection' will sometimes return an invalid username result...

    @Kris - BlogStomp will and does work with wordpress.com just sometimes, for the unknown reason, wordpress rejects our request. Don't worry between the wordpress team and ours we'll figure it out.

    Cheers
    Danny

  16. Hm, I'll pass this on and see if I can get any input on that. Thanks for letting us know!

  17. oldspicethroughtheages, what is the request that you're sending? When it breaks, what is the response you get back from WordPress.com?

  18. Hey mdawaffe,

    Thanks for getting back!

    We have a test connection feature and for simplicity sake we'll only consider that aspect.

    That 'test connection' simply retrieves the first post of the blog based on users credentials. That fails with a bogus 406 error, sometimes, despite no credentials (or code) changing.... My hunch was a restriction on the number of requests...

    Again, thanks for your help!
    Cheers
    Danny

  19. My Blogstomp was happily uploading my blogs to wordprress.com, until today? :(

    Not sure whats changed?

  20. Mine has suddenly stopped working too!! (sad face)

  21. I'm convinced WP has changed something? Perhaps to stop third party apps from posting? I cant use the native WP front end to post blogs, its tedious, clumsy, not intuitive and time consuming.

  22. Hi All,

    Update. Without changing any code we are now getting an error while posting to WordPress.com blogs, with an unhelpful response.

    Fault Code: 500
    Fault String: You are not allowed to do that

    This does, as focalperfection suggests, seems like a blocking from WP?

    The code hasn't changed it worked before and now doesn't. I hope to hear from WP very soon, in the mean time I will work on alternative solutions.

    Cheers
    Danny
    (a BlogStomp Developer)

  23. Sorry I posted from a clients account (as I was testing the issue he reported)

    Same again, from me this time....

    Hi All,

    Update. Without changing any code we are now getting an error while posting to WordPress.com blogs, with an unhelpful response.

    Fault Code: 500
    Fault String: You are not allowed to do that

    This does, as focalperfection suggests, seems like a blocking from WP?

    The code hasn't changed it worked before and now doesn't. I hope to hear from WP very soon, in the mean time I will work on alternative solutions.

    Cheers
    Danny
    (a BlogStomp Developer)

  24. I too am no longer able to upload to my blog on wordpress.com and it was working until I tried today.

  25. This thread has been tagged for Staff attention. If you subscribe to the thread you will be notified when Staff respond.

  26. Hi Danny - we'll get in touch with you by email to sort this out. In future feel free to contact us at support AT wordpress.com anytime, so we can work with you directly on resolving any issues. Thanks very much!

Topic Closed

This topic has been closed to new replies.

About this Topic