Need help? Check out our Support site, then


Bug in Firefox prevents editing

  1. I'm encountering a weird bug that prevents me from editing or adding posts in my WordPress.com blog:

    - After the Edit view (for existing or new posts) finishes loading, the same view is loaded inside the "Categories" box. The "All Categories" tab seems to be replaced with a "Loading..." text and animation and I can scroll around the categories box and see the whole sidebar of the WP Admin column. Inside the categories box!
    - When the page-within-the-page has finished loading, I get the "Are you sure you want to navigate away from this page? [...]" alert. This happens without me clicking on anything on the page.
    - If I click "Cancel" I immediately get the same alert box again until I click "OK".
    - If I click "OK", the page reloads with the same URL, but it seems that CSS is disabled.

    This happens on Firefox 3.0.5 in OS X 10.5.6. Until yesterday, I've used the same setup to access WordPress.com without problems. I haven't added or edited any Firefox add-ons since then.

    The bug doesn't happen in Safari.

  2. In FF, log out of wordpress, clear your browser cache and cookies (tools > clear private data) then restart FF and try again.

    If that doesn't do the trick, then go in and turn off all addons in FF and then try it. If that works, then turn the addons back on one at a time until you find the one that is causing issues.

    I use FF on 10.5.6 and have no such issues.

  3. I also have a problem with Firefox shutting down all the time when I'm working on my blog....drives me insane..Lots when I'm viewing video....ouch

  4. Thanks thesacredpath, clearing cookies and cache didn't have any effect, but I found the culprit by turning off add-ons: the strange behaviour is caused by the latest version of Firebug, which was recently updated. For some reason, Firebug 1.3.0 messes with wordpress.com even when "suspended" - only disabling it completely and restarting Firefox resolved the issue.

    Since I can't live without Firebug, I'll be using Safari for WordPress.com...

  5. Someone else had mentioned that also, but I had shrugged since I'm using firebug 1.3.0 on FF 3.0.5 Mac and do not have any issues at all.

    Oh well, keep it turned off till they send out another update I guess, and I'll file the firebug issue away in case the problem crops up again.

  6. Firebug is great, but you might want to try web developer. It has a lot more capability and I'm just starting to use it a lot. I do like Firebug though and expect I'll still use it quite a bit. It's quick for figuring out blog issues here.

  7. Thanks again, I'll check out web developer.

    The issue is reported on Google Code as a Firebug bug ;-)

  8. You're welcome, and thank you for posting what the problem was. Again, it may very well be helpful for others.

  9. Have you tried resuming Firebug? I had the same issue, but found out it only happened when I had suspended FB, thanks to this.

Topic Closed

This topic has been closed to new replies.

About this Topic