Need help? Check out our Support site, then


BUG - Spectrum Theme

  1. So, I went to my website using Internet Explorer 7.0 and i saw this: http://img535.imageshack.us/img535/1113/disvx.jpg

    This is the bug: I can't click in the itens of the main menu because it goes behind the content instead going in front of it...

    By the way, in Mozilla Firefox the site seems pretty well...

    Does anyone else had this issue?

    The blog I need help with is erevenews.com.

  2. dropdowns

    To clarify: By now, all themes that feature a top nav menu support dropowns if you replace their standard menu with a custom one. But only some of those themes support dropowns in their standard menu, and Spectrum isn't one of them. http://en.forums.wordpress.com/topic/spectrum-theme-how-to-dropdown-menu-for-child-pages?replies=6#post-548820

    In short Spectrum does not support dropowns in the standard menu. You need to create a custom menu and then include the sub-pages (child pages) in it > http://en.support.wordpress.com/menus/

  3. Well actually I am using a custom menu.

  4. Internet Explorer has known issues and takes a ton of work to get anything to work with it. Since you have posted in the themes forum, the theme team will see this and they will respond. Hopefully it turns out to be something simple to fix, but with IE, you never know.

  5. Hmmm ... I just randomly clicked some dropdowns and they worked for me using Firefox 3.6.13 like you said above. Sorry my comment wasn't helpful. You will have to report this IE7 problem to Staff. > http://en.support.wordpress.com/contact/

  6. OOPS! Please don't use that contact Staff link. I forgot Staff told us they prefer to monitor threads in theis Themes Forum. :( Time for a coffee ...

  7. Well its not such a big deal but i'm gettin more and more pageviews everyday, so I don't know wich browser my readers use...Hope they fix this soon =(

  8. I have had trouble with the Spectrum theme ever since I set up my blog. The text in the title overwrites the date and makes both of them illegible. I have not made any customizations and this problem occurs with both Explorer and Firefox. I have inspected the page source using Dreamweaver CS4 and it is pretty clear why this is happening. I have contacted WordPress tech support numerous times, and they state that their technicians are working on it. I don't really believe them any more because this particular bug has been reported numerous times in the forums since last October. I like the Spectrum look, but the bug really detracts from the appeal of the page, so I am currently looking around for a different theme.

  9. @fullfrogmoon
    How can anyone help you when you havehave not provided the URL starting with http:// failed to link your username to the blog in question?

    Here’s how to link your username to your blog in your blog Dashboard -> Users -> Personal Settings -> then scroll down to Account Details. Then scroll down to where it says ‘Website‘ select the URL for your primary wordpress.com blog starting and then save changes.

    Now every time you sign into the forum we can all click on your username and your blog will be linked to it. And every time you leave a comment on a blog your username can be likewise clicked and your blog can be instantly located.

  10. @fullfrogmoon, if you had the CSS upgrade, the following should fix it. I say should because 375px is a little bit of a guess since I don't have a December date to check, and of course it would have to be checked in other browsers as well. Also, if someone happened to zoom in with their browser, or had it set with a larger font size than the default, the date could still end up overrunning the right end of the title.

    .main-title h3, .main-title h3 a {
    max-width: 375px;
    }
  11. Hi Timethief,
    Thank you for your assistance. I am relatively new at blogging. I had seen the Website field in the user section, but I thought that it referred to a personal website hosted elsewhere, not my WordPress blog. I have now entered the information you require.

  12. Truthfully, what I would probably do in addition to setting a max width for the title, is to change the month to the 3-letter abbreviation to give more room for the title.

  13. @fullfrogmoon I suggest changing your site's date settings in your dashboard, under Settings > General. If you do something like 05/05/11 it will not overlap.

    The original theme design had all dates hardcoded to always be like that, but since we have so many sites with different languages and date settings on WordPress.com we generally let you as the site owner decide on date format display.

    In this case a shorter date format will work much better than a long one. :)

  14. Thanks to everybody for helping me with this problem. Changing the date to a shorter format was a quick and easy solution. Once I get a little more comfortable with WordPress, I will get the CSS upgrade and begin to customize my blog.

  15. I think it looks nice now. :)

  16. So that means if I want to fix this problem at Internet Explorer I gotta buy the CSS Upgrade?

    If so, no thanks I'll tell my readres to use Mozilla Firefox. lol

  17. Flaviomian: In my case, the problem persisted with both Explorer and Firefox. Also, keep in mind that new readers may be using Google with a variety of browsers when they find your site for the first time, so it is important that your blog renders properly under all browsers so that you create a positive initial impression. Try the solution recommended above by Lance, which does not require the CSS upgrade.

  18. @fullfrogmoon the Lance's solution is for the date overlap in posting....my problem is at the menu that keep going behind the content of the website.

Topic Closed

This topic has been closed to new replies.

About this Topic