Need help? Check out our Support site, then


Bushwick Theme Not Working In Internet Explorer

  1. I think the issue I'm having is related to: http://en.forums.wordpress.com/topic/fix-cant-see-words-typed-in-editor-box-when-creating-post-in-bushwick-theme?replies=8

    I tried clearing my cache and cookies to no avail :-(

    The theme looks just as expected in both Firefox and Chrome. Looks great.

    However in Internet Explorer, it looks great only as a Preview. But once I hit "Activate" it looks terrible. The only things visible are the images. Everything else is shrunk super SUPER small. I'd guess the font size was -0.5, it's sooooooooooooooooo tiny. Can't see the menus, links, buttons, nothing, everything is über small.

    It is not just terribly tiny when looking at the published post. It is super-small while trying to edit the post too. I tried creating a new post from scratch and the problem was still there. The font was so tiny that I couldn't even see what I was typing. There was no way to make it bigger either. Shouldn't have to, because everything displays as normal in Chrome and Firefox, both published and in edit mode.

    I haven't tested any other browsers like Opera or Safari. Is it possible to have the theme fixed so that it works across platforms? Or at the very least, that it displays an error message in browsers where it can't be display correctly? (it should at least work in the most popular browsers: IE, FF, Chrome and Safari).

    If you need a screenshot, please let me know. Most likely, I will switch back to the old theme I was using until this technical issue is fixed.

    I hope that you can fix it soon, because I really like the theme. I like how it looks like a print book.

    Thanks for your time!

    The blog I need help with is crowncasting.wordpress.com.

  2. I spoke (or typed) too quickly about Chrome. Chrome doesn't have the IE issue of "tininess", however the font doesn't look like in the Preview. It looks quite "grainy" in Chrome. The only browser displaying the theme true to the Preview is Firefox.

  3. Bump. It's been two weeks and no one has replied to my thread, let alone resolved the problem.

    My WordPress blog still looks ridiculous in an Internet Explorer browser using the Bushwick theme. How long will it take to resolve this issue? Shouldn't WordPress themes work regardless of the browser?

  4. Even the live demo of the Bushwick theme doesn't work in IE: http://bushwickdemo.wordpress.com/

    If there was a way to upload screenshots, I would.

  5. I see a consistent display across FF 26.1, Chrome 32 and IE 11.
    Exactly which browser versions are you running please?
    WordPress.com supports the browsers and versions of them found here http://browsehappy.com

  6. I'm using IE version 10, and according to the chart in the article below, sourced from StatCounter data, half of IE users are on an old, outdated version of IE: http://www.zdnet.com/despite-automatic-updates-old-browsers-are-still-a-problem-7000024778/

    If WordPress doesn't want to support old versions, at least code your templates to check the version that the site is being browsed on. If the version is not supported, then display an error message that lets the user know that they can only enjoy the content on the most current version of their browser. You could in addition supply the browsehappy link so that they can decide if they want to use another browser. This is just basic error handling, and I'm shocked that it hasn't already been implemented.

    I think it's unacceptable to just allow the theme to render in old browsers in a ridiculous-looking way. The end user doesn't know that their browser isn't supported. All they know is that they navigated to the site and it looks like a joke. They will lose interest and navigate away.

  7. Note the Bushwick is a responsive layout theme http://theme.wordpress.com/themes/features/responsive-layout/ Know that responsive width means the layout adapts depending on the size of the device being used to view your site. When responsive width themes are viewed on mobiles sidebars appear below the posts in order to provide as much space as possible for reading.
    Go to > Appearance > Mobile and disable the mobile theme

    I'll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting. Please post screenshots, upload them to your Media Library, and return to this thread to provide the file names so Staff can examine them.

    P.S. Only 2.1 % are recorded here as using IE 10 in December 2013 http://www.w3schools.com/browsers/browsers_explorer.asp

  8. To link your username to your active blog rather than the deleted one see here > http://onecoolsitebloggingtips.com/2007/10/06/link-your-username-to-your-blog/

  9. Hi Timethief,

    The link you provided showed that IE 10 was 2.1% of all browser users, including other versions of IE, and all versions of Firefox, Chrome, Safari, and Opera. The w3schools statistics actually validates what I said, because their numbers are less conservative than the article I posted. They are basically saying that 9% of people use IE, and out of that 9%, only 0.8% are on IE 11, which is the version that WordPress supports. So the other 8.2% of people that choose IE when browsing will not be able to view WordPress Sites correctly.

    In fact, if I use the w3schools source that you supplied, WordPress themes will only display correctly for 10.9% of people, because this is the number of people using the most current version across platforms that WordPress currently supports (I couldn't include statistics for Opera, because WordPress only supports version 19 and the w3schools statistics stopped at version 18). This figure is based on 0.8% IE 11, 1.0% Chrome 32, 6.9% Firefox 26, 2.2% Safari 7. This means that 89.1% of people will not be able to view WordPress sites correctly because they use unsupported browsers.

    I am subscribed to the thread to be notified of any response.

    I uploaded a screenshot to my media library. The name of the file is "Screenshot_Buskwick WP theme in IE 10". I don't have access to a mobile device right now, so the screenshot is from my computer.

    I tried your instructions to link my username to my active blog, but when I got to the "Primary Blog" droplist, the active blog was already selected, and it was the only option available in the droplist.

  10. I am subscribed to the thread to be notified of any response. ...I uploaded a screenshot to my media library. The name of the file is "Screenshot_Buskwick WP theme in IE 10". I don't have access to a mobile device right now, so the screenshot is from my computer.

    Thanks for that added info for Staff.

    P.S. See here http://www.responsinator.com/?url=http%3A%2F%2Fcrowncasting.wordpress.com%2F

  11. Hi Timethief,

    You're welcome. If you need any more info, please let me know.

    Thanks for the link to responsinator.com, it is very helpful.

  12. You're welcome and please be patient while waiting. It's a weekend and there are many threads tagged for Staff. They work their way through, as would be expected, by addressing those with the earliest datestamps and time stamps to the most recent ones.

  13. Hi there,

    Thanks for providing those details and the screenshot — that really helps. It looks like you have Internet Explorer's Compatibility View turned on. That can cause problems for how webpages are displayed. When I turn off compatibility view in IE 10, your blog looks just fine to me.

    Can you please try turning off compatibility view and see if that fixes the issue for you? You can find more information about that here:

    http://windows.microsoft.com/en-us/internet-explorer/use-compatibility-view#ie=ie-10

  14. Hi rachelmcr,

    Thanks for looking into the issue for me. I was able to get my blog to display correctly by disabling Compatibility View. However that doesn't fully solve the problem, for a few reasons:

    1) Unless there is some kind of error handling, readers may encounter the same problem and not know it's due to Compatibility View being turned on, and...

    2) My blog looks like that in IE 10 when I'm trying to write or edit it. Which makes it impossible to write or edit, because the font looks so tiny. I uploaded another screenshot to my media library so that you can take a look. It's called "Screenshot_Inside my WordPress post editor in IE 10". There is no button that appears to switch on/off Compatibility View, so I am stuck with this if I want to edit in IE 10. (You can see in screenshot that the CV icon does not appear...)

    3) Also, I don't understand why the fonts display differently in different browsers. It doesn't look as expected in IE 10, even after Compatibility View is turned off. It looks as it should in FF, which is a slab-serif font for the headers, and a sans-serif font for the body. In IE 10, it is all serif font. The style of the fonts is one of the reasons I selected this theme.

    Thanks again.

  15. Hi there,

    1) Unless there is some kind of error handling, readers may encounter the same problem and not know it's due to Compatibility View being turned on

    Thanks for that feedback. We don't have a way to alert readers to that kind of issue at this point, but I passed this along to our developers to see if there's a way we can add that in a future update.

    2) My blog looks like that in IE 10 when I'm trying to write or edit it.

    I see what you mean. Can you please try clearing your browser's cache to see if that fixes it for you? If it doesn't, please let me know and I can keep investigating that.

    3) Also, I don't understand why the fonts display differently in different browsers. It doesn't look as expected in IE 10, even after Compatibility View is turned off.

    Could you make a screenshot of how you see the fonts in your browsers? I'd be happy to look into this for you, but I want to make sure I'm seeing the same fonts that you are. :)

  16. Hi rachelmcr,

    I tried clearing the cache, but it still looks the same :-(

    Per your request, I've added two screenshots to help you determine the reason why fonts are displaying differently in the different browsers. They are named, "Screenshot_Bushwick Fonts Displayed On FF 26" and "Screenshot_Bushwick Fonts Displayed On IE 10".

    Thanks again.

  17. Hi there,

    Thanks for letting me know, and for the additional screenshots.

    After some additional testing, I am seeing both of the issues you reported (the small font in the editor and the different font on the blog itself) when I use IE10. It looks like there's an issue specific to IE10, and I am passing this along to our developers so they can look into that. Thanks for reporting this!

    I also tested IE11, and it's working just fine in both the editor and with fonts on the front end of the blog. While we look into the issue with IE10, you may want to consider updating to the newer version of IE if you can.

  18. Hi there,

    Our team fixed the issue with the post editor in IE10, so it's working now. If you still see that small font in the editor, you may need to refresh your browser or clear your browser's cache. Please let me know if you continue to have trouble with that.

    For the fonts on the blog itself, we are sending Internet Explorer the correct fonts for the blog, but for some reason IE10 doesn't display them. I checked on IE11 and the fonts work as expected, so it seems that in that version they fixed the issue preventing the fonts from showing up in IE10. If you can, you may want to update to the latest version of Internet Explorer, which you can download here: http://browsehappy.com/

Topic Closed

This topic has been closed to new replies.

About this Topic