Need help? Check out our Support site, then


Can you disable comments on an attachment page?

  1. magalieandtravis
    Member

    I have 1 image that is getting tons of spam comments. Unfortunately, none of these are getting picked up by the spam filter. Is there any way to disable comments on an attachment page? Or do I just have to manually mark everything as spam? After 1000 spam comments I am getting really fed up with this. Thank you!

    The blog I need help with is magtravels.wordpress.com.

  2. Take a look at this.

  3. The link links to a workaround of mine, but now there are two possibilities - see updated version of my post:
    http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

  4. dogleadermysteries
    Member

    Thanks for your suggestions. I too am now getting tons of spam due to attachment comment boxes.

    My blog too has developed a quirk in attachments. I do not see any settings for shutting them off on photograph attachments. Is this some new tweak from WordPress?

  5. Quoting from my post:

    go to Media > Library and edit each image to disable commenting in its own Discussion module. Again, to make the Discussion module show up, click Screen Options.

  6. magalieandtravis
    Member

    Thank you! Funny how the "hide" the discussion module.

Topic Closed

This topic has been closed to new replies.

About this Topic