Need help? Check out our Support site, then


Cannot add media

  1. Hi,

    At the moment I have no 'add media' button in the main editing page for this blog (which I contribute to but don't 'own'). When I go to full-screen typing mode the 'Add media' button appears, but every time I try to upload a photo it says there's an error.

    The blog I need help with is mancultural.wordpress.com.

  2. Hello there,

    I'm sorry about the trouble you're having. Can you please confirm few things for me?

    Can you take a look at this screenshot of the toolbar where the Add Media button is supposed to appear?

    https://i.cloudup.com/KPjO26nuAa.png

    It should appear right before the "Add Poll" button. If you don't see it, please take a screenshot of the toolbar that you are seeing so I can investigate.

    http://en.support.wordpress.com/make-a-screenshot/

    It might also help to clear your browser cache as having a corrupted cache can cause things to not appear correctly.

    http://en.support.wordpress.com/browser-issues/#clearing-your-browser-cache

    If uploading an image remains an issue, please try using the browser uploader and see if that makes a difference. You can switch to the browser uploader by clicking on the "browser uploader" link on this page:

    https://mancultural.wordpress.com/wp-admin/media-new.php

    Please let me know soon what your findings are. Thank you!

  3. Hi,

    I'm not the administrator for the blog, I'm a contributor. I wrote a post a few weeks ago into which I was able to insert images the same as in my own blogs. Now I have the toolbar that you've sent me only on my own blogs, but not the mancultural blog that I contribute to, for that I have a different toolbar with no option to add media, or a poll, just the one with the blod, italics, add link etc buttons. When I go into full screen mode I do have a media button, but still keep getting this error message.

    I tried to add an image into the post via the WordPress app on my phone, to see if it was a browser issue, and I still got an error, but this time it told me that I don't have permission to add images. However I was able to do this in my last post. Also I can't understand why - what's the point of me only being able to contribute text? My colleague who owns the blog on his account has to publish it, but I don't understand why I can no longer see the same toolbar or add pictures.

  4. Hi there!

    I'm not the administrator for the blog, I'm a contributor.

    Thanks for clearing that up. Unfortunately, contributors are not allowed to upload files or images.

    http://en.support.wordpress.com/user-roles/#contributor

    I would ask the blog's administrator to assign you as an author to have this capability.

    Let me know if there are other questions or concerns you had in mind. Thank you!

You must log in to post.

About this Topic