Need help? Check out our Support site, then


can't add image from url

  1. I've searched support and forums and haven't been able to resolve this problem. I'd like to be able to insert an image into a post by linking to the URL, but when I click on the "add an image" button and paste the URL into the box, instead of getting a green checkmark I get a red "x". Here's the URL I tried: http://3.bp.blogspot.com/_rlbkVRdQg0w/SmeE8UcUBJI/AAAAAAAADKE/dBQIrJ_3ubc/s1600-h/headofayounggirl1884.jpg I found a response to someone else with a similar problem saying you have to have a url for an image, not for a web page, but this one does end in ".jpg." Why isn't this working for me? Many thanks.

    The blog I need help with is lawandconversation.com.

  2. It appears to me that blogspot.com is blocking our script's attempts to determine the file type. Are you able to download the images and upload it into your WordPress.com blog instead?
    http://en.support.wordpress.com/images/#from-your-computer

  3. Yes, I can do that just fine. Would rather not have to, but sure, that's a workaround I can live with. Are there any other sites that present similar problems with images?

  4. I've never heard of this particular problem with Blogspot images before. It must be new.

    Can you visit your blogspot settings and check if you've enabled hotlinking? If you've disabled it, then obviously it won't ever work until that setting is changed. I seem to recall Blogspot allows you to configure that.

  5. I can't think of any specific ones right now, but there are some. Some sites block images from getting embedded on other sites all together. It's fairly rare though.

  6. Oh wait: are you using any fancy Picasa code to put the image in WordPress.com? Because javascript etc are stripped out here and that could be interfering. If you're just using

    <img src="http://3.bp.blogspot.com/_rlbkVRdQg0w/SmeE8UcUBJI/AAAAAAAADKE/dBQIrJ_3ubc/s1600-h/headofayounggirl1884.jpg">

    and still getting this error, I'm afraid I'm stumped.

  7. @raincoaster Good idea to check to see if there's a setting on the blogspot side.

  8. I don't know what you mean by visiting my blogspot settings. I don't have anything on blogspot; the site I referenced is someone else's. The only thing I did was copy and paste the URL from my browser into the box that comes up on my blog when I click the "add an image" button; I didn't add or subtract any code from it.

  9. Ah, then that particular blogger might have disabled hotlinking. There's nothing much you can do about that. Copying it to your hard drive and re-uploading it is the only way to do it.

  10. Oh, OK. I found the site through another blog that uses the images via links--but that's a blogspot blog. So does it seem to you that the problem is the interface between blogspot and wordpress? Many thanks to all for your helpful, not to mention lightning fast, responses.

  11. You know, I just tried this image http://lh3.ggpht.com/_v68WnMKHlKQ/S84hjiYSJ_I/AAAAAAAABQA/6-kAUe_oHHI/s1600-h/blog56%5B4%5D.jpg , which is not from blogspot, and I got the same problem. So I'm again at sea.

  12. Why hotlink at all? Why don't you simply capture the image and upload it into your post?

  13. Oh, OK--I didn't realize I could do that. And now I can have it link to its URL, too. Thanks much for all of your help!

  14. As it turns out, Blogspot is not blocking the image. The URL you're using isn't the actual image even though it sure looks like it ought to be. That URL is an HTML page, not an image.

    I'm not sure where that URL came from, or why blogspot is serving as HTML.

    Try using

    http://3.bp.blogspot.com/_rlbkVRdQg0w/SmeE8UcUBJI/AAAAAAAADKE/dBQIrJ_3ubc/s1600/headofayounggirl1884.jpg

    instead.

  15. Aha! I opened it and saw a plain image and didn't think to check the source.

    Hey @mdawaffe, you are smart! :)

Topic Closed

This topic has been closed to new replies.

About this Topic