Need help? Check out our Support site, then


Cant add links anymore on new posts

  1. I have noticed lately that I can't add links anymore when creating a new blog. The icon on the top bar for creating a link is light grey, can't click on it. I try going to Text and add a link that way, but it doesn't work there either. This problem started happening only in the past week I would say, it was fine before. What has changed? Did I click on something by mistake and change my settings? Thank you for help to get my site back in perfect working order.

    The blog I need help with is lisettedefoe.wordpress.com.

  2. You have to highlight the anchor text you want to link to first with your mouse and then the chain icon link in the editor becomes active.

  3. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache:

    http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/ and also post any error reports you get.

  4. This is the general link model:
    <a href="URL HERE">Highlighted anchor text here</a>
    This is the visual result but as it's just an example it's not actually linked to a page:
    Highlighted anchor text here

    Enter the anchor text you want to link to first.
    Then use your mouse to highlight that anchor text.
    Next click the chain icon in the Visual editor and proceed to create the link.

  5. Duuuuuuh!!! Thank you timethief!!! I usually work from my iPad, so I forgot I have to highlight the text first. I was so confused why it wouldn't work. Thank you so much. You are a life saver!

  6. You're welcome. :)

Topic Closed

This topic has been closed to new replies.

About this Topic