Need help? Check out our Support site, then


Can't Authorize Twitter

  1. I tired to authorize Twitter to publicize my blog through the My Blogs admin window. It seemed to work at first. But, when I returned to WordPress it said that there was a problem authorizing it and I should try it again. However, when I try to re-authorize, I now get this message from Twitter:
    "Woah there!
    This page is no longer valid. It looks like someone already used the token information you provided. Please return to the site that sent you to this page and try again … it was probably an honest mistake."
    HELP! Please!!

    The blog I need help with is cavemancooking.wordpress.com.

  2. Have you made any new posts (not PAGES) since you did that? Because it won't update your Twitter until you do.

  3. Yeah, I did. Thanks.
    Though, I have resolved this situation by revoking the authorization on Twitter, then unchecking Twitter on my blog, and then starting the process over again. It worked the second time around.

  4. I'm getting the same error. But when undo and redo and go to twitter and allow the connection then come back to WordPress it says, in red: An error occured authorizing your Twitter account.

    Then clicking again gets back to the same "Woah there!
    This page is no longer valid. It looks like someone already used the token information you provided. Please return to the site that sent you to this page and try again … it was probably an honest mistake."

    It has nothing to do with updating pages. Of course that won't work until twitter is authorized.

    What's weird is that it was authorized last week.

  5. The site linked to your name isn't a WordPress.com blog and we won't be able to help you with that. Please change the link so we can give you appropriate advice.

  6. i to am getting this same error, how do i revoke or change the setting ?

    i got my yahoo to accept, but instantly i tryed to do twitter authorize, and i get Whoa there. some one used your token, i have tryed several new posts. and i get the same error 404 every time.

    i dont know what else to do. please help.
    i read the posts above, but there's not a lot of details on how to fix this problem.

  7. @dekun1
    The blog linked to your username is NOT a wordpress.COM blog. We provide support ONLY to bloggers with wordpress.COM blogs.

  8. I am getting the same error message as above, and I cannot resolve. Getting tired of having to copy and paste the updates into my Twitter each time I post. I do have a WP blog. Your assistance will be greatly appreciated! Thank you!!!

  9. I have several wp blogs and have the same message when trying to connect to twitter. Its very frustrating.

  10. toashishagarwal
    Member

    Even I am getting the same error message... cant figure out if its a problem in twitter or wp...

  11. Gosh I hope every time twitter goes down we don't get a tsunami of confused bloggers posting here ... lol :D

  12. Twitter is working -- I just manually posted a new blog post to it. But over the past several days i have tried to use the "authorize Twitter" button on wordpress to publicize my wordpress.com blog posts [myowntimemachine.wordpress.com] and I get the same error message as listed above. ["Woah! Someone already used the token information" etc]

    No answers here, but I saw there was another forum thread with the same issue, so will check over there and keep my fingers crossed.

  13. Hi, I am having the same problem. My blog used to post to twitter but is no longer doing so. After clicking the authorize twitter box on wordpress.com, I am taken to a twitter page that says - This page is no longer valid. It looks like someone already used the token information you provided. Please return to the site that sent you to this page and try again … it was probably an honest mistake.

    I have tried to redo this several times but get the same error. I can post manually to twitter, with no problems.

    Thanks, Anne

  14. @nanneweaver
    You forgot to post the complete clickable URL for you blog. Will you do that now please? No one can help you if they do not know which blog you are referring to.

    Rather than having to post the blog URL every time you post to the forum you can opt to link your username to your blog. It’s very easy to do. Dashboard> Users > Your Profile. Scroll down to where it says ‘Website‘ and fill in the complete clickable URL for your blog starting with http:// and then click ‘Update Profile‘.

  15. interestingevan
    Member

    Is there an actual work around for this ? this is getting silly... my blog is http://interestingevan.wordpress.com any assistance would be much appreciated

  16. I have the same problem and cannot figure it out , works fine with one blog and not the other.

  17. Go to dashboard -> My blogs -> remove all the checks from the twitter, facebook, and yahoo updates. Then check each individually, wait for the confirmations. Then open up a new post page and in the right side window you should see that all are enabled. You are good to go then. Good luck!

  18. @fukutoshin: That didn't work for me.. I still can't use twitter on the blog..

  19. Can you try clearing browser cookies and then try authorizing from the My Blogs page again?

  20. @fukutoshin Worked for me! thanks so much!

  21. @fukutoshin THX dude!!! this was really starting to get very annoying. i tried everything, but your solution did it!

  22. I'm having the same problem with authorizing my Twitter account (I get the "Whoah, there" message, I think because I entered the wrong password the first time.) I have tried to uncheck my Twitter box, but it never unchecks. I hit "apply" every time, and I have cleared my cookies several times, and even told my computer to forget all my passwords in case that was the problem.

    HELP!!!!

  23. I was able to resolve my problem by going to a different computer, which allowed me to uncheck the Twitter Publicize box. Don't know why my computer wouldn't let me uncheck it....

Topic Closed

This topic has been closed to new replies.

About this Topic