Need help? Check out our Support site, then


Can't comment on blogs without the ".wordpress"

  1. Hello,

    Since yesterday, I haven't been able to "like" or comment on any blog without the ".wordpress" in the address. For example, http://andrawatkins.com/ or http://broadblogs.com/

    The blog shows me the comment box, then asks me to enter my email, name, and blog address. When I do and try to login, the screen refreshes, but my comment does not appear. If I try this again, I get an error message saying that my comment is a re-post, but my comment never actually shows up (not even hours later).

    Help?

    The blog I need help with is jenniesaia.wordpress.com.

  2. The blogger here http://andrawatkins.com/2013/06/28/like-a-dagger-in-the-back/#comment-50361 has set up comment moderation and I left a comment.

    timethief #
    Please Note: Your comment is awaiting moderation.

    This is a test comment being made due to a support forum post. Please delete it.

  3. OK. I see the comment on BroadBlogs now, too, and I'm glad. Thanks for investigating! But, if I can have another question, I don't feel like this is resolved: for one, I never got a notification that BroadBlogs had replied to my comment, which is unusual.

    Also, I usually don't get moderated on Andra's blog, since I've commented before - I assume she uses the 1-and-good option for comment moderation. But even so, for her and every other blog without the ".wordpress", I've been asked to login multiple times, which had never happened to me before.

    Here's a screenshot of the message I receive: http://jenniesaia.files.wordpress.com/2013/06/screenshot.png

    The thing is, I *am* logged in - I'm working on a post and in dashboard and commenting on other blogs, etc.. And when I *do* re-login, I still get this strange log-in request the very next time I try to comment anywhere.

    But again - only happening on blogs without the ".wordpress" - everywhere else, I am commenting as normal.

  4. I'm having similar issue, but only when using Internet Explorer. When I use other browsers it works fine.

  5. But, if I can have another question, I don't feel like this is resolved: for one, I never got a notification that BroadBlogs had replied to my comment, which is unusual.

    Unless the blogger chooses to activate this setting and you choose to click to be notified of every comment on that post you won't be notified.
    Settings > Discussion
    scroll way down to:
    Follow Comments __ Show a 'follow comments'' option in the comment form

  6. Here's a screenshot of the message I receive: http://jenniesaia.files.wordpress.com/2013/06/screenshot.png

    The thing is, I *am* logged in - I'm working on a post and in dashboard and commenting on other blogs, etc.. And when I *do* re-login, I still get this strange log-in request the very next time I try to comment anywhere.

    How many WordPress.com username accounts do you have please?

  7. But again - only happening on blogs without the ".wordpress" - everywhere else, I am commenting as normal.

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache: http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies and JavaScript enabled: http://en.support.wordpress.com/third-party-cookies/

    http://www.google.com/adsense/support/bin/answer.py?answer=12654

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/ and also post any error reports you get.

    P.S. I'll tag this thread for a Staff follow-up. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  8. @oegukeen

    I'm having similar issue, but only when using Internet Explorer. When I use other browsers it works fine.

    Exactly which version of IE are you using? Check here if necessary http://www.whatbrowser.org/
    Are you running the browser in compatibility mode/
    Are your running it in privacy mode?

  9. @timetief
    I'm using IE10, it wasn't in compatiblity mode, and wasn't in InPrivate mode.

    This has been happening for a few months now. When I go to wordpress.com blogs that don't have wordpress.com domain name I can see the grey (or black) bar with my username on the top, but in the comment box it looks like I'm not logged in.

    When I try to connect my wordpress.com account it seems like a window is trying to pop-up but nothing really happens (I tried turning pop-up blocker off, didn't help).

  10. Thanks for that additional information. Please be patient while waiting for Staff.

  11. @oegukeen,

    Do you have cookies enabled for WordPress.com? It sounds like your browser is not allowing you to remain logged in as you navigate between pages.

    Please see: http://en.support.wordpress.com/third-party-cookies/

  12. Hello again,

    Thanks to you both for your help. timethief, I only have one account: jenniesaia

    jackiedana - I am still experiencing the exact same problem that oegukeen described - all the details match. I ran through all the troubleshooting that timethief prescribed, and, at the link you posted, I got the green light that third party cookies are enabled.

    Still, I can't like or comment on blogs without "wordpress.com" in the domain name. When I try, I get the pop-up box's effort to log me in even when I am already logged in.

  13. Hi jenniesaia,

    Are these blogs asking you to enter an email address to comment, and are you then being told you need to log in? If you use the email address matching your WordPress.com account, that will authenticate you and you should be able to comment. If you run into problems at that point, this often happens if you try using an email address that is either not associated with WordPress.com or is associated with a different account.

    Can you list out a blog or two where you run into this problem, and can you let me know what happens when you follow the directions to log in? Are you able to comment at that point, or are you blocked, and what message do you receive at that point?

  14. @jackiedana

    My cookies are enabled, I checked. Also I have no issues with previewing posts nor staying logged in on blog which have .wordpress.com

  15. @oegukeen can you provide the same info I asked of jenniesaia? This will help us troubleshoot the issue further.

  16. @jackiedana

    I am not entering any e-mail addresses. I only have one e-mail address I use for this so even if I did have to input it there would be no mix-up.

    Since I am already supposed to be logged in I just click the little wordpress logo right underneath the comment box (it is left of the twitter and facebook log-in logos).

    Then a window pops up with this URL "http://jetpack.wordpress.com/public.api/connect/?action=verify&service=wordpress" but it closes automatically without anything changing. Sometimes if I am stubborn enough and click a lot of times it does eventually connect.

    http://atkmagazine.com
    http://modernseoul.org
    http://fromkoreawithlove.org
    would be an example when this happens.

    I also have the same issue if I try to like the post. A window pops up
    with the URL "https://wordpress.com/public.api/connect/?action=verify&service=wordpress" but then it quickly disappears and nothing happens.

  17. @oegukeen,

    I just went to the first blog you mentioned, and clicked on a recent post. I'm currently logged into my WordPress.com account, and this is what I see when I click in the comments box: http://cl.ly/image/0g2p0f0a3e47

    If you have to click on the WordPress logo it sounds like you're not logged in when you try to comment.

    Do you have any popup/spam blockers installed in your browser or on your computer? Could you try a different browser to see if you have the same issues?

  18. @jackiedana
    re: the first URL http://atkmagazine.com
    I see exactly the same thing you see. I'm using Firefox 22, Chrome 27 and IE8 on my PC. I'm not using any spam blockers, compatibility mode or private browsing settings.

  19. @jackiedana

    As I said above, this only happens in Internet Explorer, other browsers are working normally.

    I am certainly logged in because I can view my dashboard, and I see the black ribbon on top and also my profile picture below the comments box just like on your screenshot but ONLY on the blogs that have wordpress.com in their URL.

    Here's the screenshot what atkmagazine looks like for me http://i.imgur.com/WmewCuN.gif

    I didn't install any additions to IE, but I am using their default pop-up blocker. However, "*.wordpress.com" is listed among allowed sites, my settings are set to medium, and notifications are on, but I don't get any notifications that anything got blocked by IE.

  20. default pop-up blocker.

    Disable it please.

  21. Ok I did, but nothing changed.

  22. Did your log out, clear your browser cache and cookies and then reboot your computer and login again?

  23. Yes, I deleted everything from my browser, restarted my computer and still same situation. Except that now I have to go back and log into all the websites I use :(

  24. Howdy all,

    Hope you had a great weekend. jackiedana is on vacation this week, so I'm stepping in to work on this with you all.

    Specifically, with Internet Explorer, we have seen that some security settings can conflict with WordPress's single sign-on across domains (e.g. IE takes exception to example.com running a script from *.wordpress.com).

    For IE, can you try to add WordPress to the trusted sites list via these instructions: http://en.support.wordpress.com/https/#frequently-asked-questions , just Items #1 and #2 are required.

    Please add *.wordpress.com and *.wp.com to that list.

    If that does not resolve the issue, please do let me know and we'll dig deeper.

    Thanks!

  25. Yes!!! That fixed it. Thank you SO much, kraftbj. For reference, I had added *.wordpress.com a while back, before the problem started. So, it was the addition of *.wp.com that seems to have been the magic bullet in my case.

    I am SO happy to have this resolved, as I use IE for all my other work and enjoy having WordPress Reader open in another tab.

    Virtual hugs!

  26. I'm happy to see this issue is now resolved. But what a crying shame that it took so long to give the https:// login a try. I recommended that here on Jun 28, 2013, 1:51 PM http://en.forums.wordpress.com/topic/cant-comment-on-blogs-without-the-wordpress?replies=26#post-1325700

  27. You certainly did recommend it! BUT that particular walkthrough of how to enable https mode only mentions adding *.wordpress.com to the trusted sites list. As I said in my last comment, I had turned on https and added that site name months ago, and it was only the addition of *.wp.com (which is NEVER mentioned in the link you posted) which did the trick.

    I'm not being snippy. I appreciate all your time and effort. I just want you to know that I did devotedly work my way through every single step of your tips and advice, and in this case they just didn't fix the problem. Perhaps the instructions for enabling https mode can be updated to include adding this second trusted site (*.wp.com)?

  28. We're checking into possibly updating the documentation. This is a relatively new particular issue/solution pair, so we want to ensure there is not something we can correct internally before suggesting users make changes as the norm!

  29. I'm so glad you pointed out that URL variation so I'll have it in mind that next time another blogger has this issue. Yes the support documentation needs an update and I tagged this so Staff will undertake that.

    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions

    Happy blogging!

Topic Closed

This topic has been closed to new replies.

About this Topic