Need help? Check out our Support site, then


Can't Delete Comment Option?

  1. How do I delete the comment option on a page? I have tried deleting it for the whole site and it seems to still be on all my pages. I want comments to be available on my blog, but not on any other page of my site.

    Any ideas how to do this?

    The blog I need help with is safeandcaring.wordpress.com.

  2. This page > Settings > Discussion is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/
    We can also override the default settings and enable or disable future comments on any post or page. http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion module hidden. You can reveal it by clicking on Screen Options on the top right corner of your Admin page, and checking the box that says Discussion.
    http://en.support.wordpress.com/enable-disable-comments/#missing-discussion-module

  3. Thanks! - I was able to go to "All Pages" and delete the options, but everything still seems to be there. Does it take some time to show up on my pages or should it have happened immediately?

  4. It's an immediate change and the guide I follow is this one > http://en.support.wordpress.com/enable-disable-comments/

Topic Closed

This topic has been closed to new replies.

About this Topic