Need help? Check out our Support site, then


Can't get static "Home" page to show as Home

  1. Greetings! I feel like an idiot but know someone out there can help me get this straight. I want my blog to have a static front ("home") page, but when I click on the links for either "home" or "news" at the left top of my page, nothing shows. My home page's post <i>does</i> show off on the right side, under recent posts, but that's the only place it lives. In short, can someone tell me how I can set up my page so that anytime a visitor clicks on "home", they'll get to my main page? I know; it's probably very simple. I'm grateful for any assistance! Thanks.

    The blog I need help with is wendyedits.com.

  2. In short, can someone tell me how I can set up my page so that anytime a visitor clicks on "home", they'll get to my main page?

    That's the default setting for every blog here.
    Dashboard > Settings > Reading

    The front page of the blog by default will display your posts (not pages) in reverse chronological order, with the most recently published post on top. If you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts.
    Choice 1 static front page
    Choice 2 running page for all posts on front page
    Which do you choose? It’s one or the other.
    If you choose a static front page then you have to create two pages as I said above. After you do that you go to > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

    Front page displays
    __ Your latest posts

    A static page (select below)
    Front page:
    Posts page:

  3. Hello! Thanks so much for the response. I'd already created two pages, but hadn't gone into settings and clicked the appropriate radio button. Your advice helped! My problem now (again, possible stupid) is that I want the very first page ("home") to contain my main, static post, not the second page ("news"). I wish for visitors who come to my site to click on "home" to get to the main page, whereas now they have to click on the second page entitled "news". Basically, my question is: how do I make the first page, in this case "home", the static page, as opposed to the second page? If you visit my site, you'll readily see my problem. Again, many thinks!

  4. Here's a little more info: when I go into the "page attributes" window in the editing page, and try to set my "parent page" to "home", I'm not allowed that option. I only have "no parent" or "news", which seems to be part of the problem. I have "home" set to page 1, but there's no way to also make it, and not "news", the main parent page. What am I doing wrong? Thanks again!

  5. UPDATE: OK, I was able to make "home" the main parent page, so now "news" is a ghost under the "home" tab. Great! However, when I click on the "home" tab in the upper left side, I am taken to a blank page still. My question is: how can I make my "home" tab work so that when someone clicks on it they are taken to the text, not an empty space (which is how it is now-empty). Thank you for your help!

  6. This has nothing to do with child pages. Edit the "News" page and turn its parent status back to "no parent" (so that the "News" tab will show next to "Home" instead of a dropdown).

  7. Thank you! This helped! I think I messed around too much with certain settings and was making it much more complicated than it needed to be (not uncommon with me). I really appreciate your help. Rock on!

Topic Closed

This topic has been closed to new replies.

About this Topic