Need help? Check out our Support site, then


can't get to my Home page in my custom menu

  1. outofedenministries
    Member

    I created a custom menu, with nested pages (I think that's what they are..?). But when someone goes to one of those pages, they can't get back to my Home page that has my latest post on it. I need to have a text widget in my sidebar that has the link back to my Home page, but I don't know how to setup the link in the text widget. Can anyone help?

    The blog I need help with is outofedenministries.wordpress.com.

  2. The back to home page link in your sidebar is linked to here http://outofedenministries.wordpress.com/ so I assume you have resolved this issue.

  3. If you prefer you can create a Home link as a custom link and include it in your custom menu. See the instructions here > http://en.support.wordpress.com/menus/#adding-custom-links

  4. outofedenministries
    Member

    Awesome! Thank you. I will do just that.

  5. You're welcome. :)

  6. I'm having the same problem, but I haven't figured it out. I want to add a Home tab at top next to About tab, so that after you click on About, you can find your way back to the home page where the posts are.

  7. Create a custom menu and then when adding the pages to it, click on the "view all" link at the top of the pages module and a "home" link should appear. Add that to your custom menu. If it does not show up, then create one using the custom links module on the menu page as Timethief suggests.

    http://en.support.wordpress.com/menus/

  8. Adding the Home tab in the navigation menu is not the problem. The problem is I cannot navigate back to the Home page where the posts are after having visiting About page.

    It's a problem using pages or custom links: the Home tab links to
    http://alltangostl.wordpress.com/home or
    http://alltangostl.wordpress.com/h/ instead of linking to
    http://alltangostl.wordpress.com (as when you first go to the site)

    I was able to delete part of the home "slug" but cannot get rid of the 'h'.

  9. I actually got it to work with a custom link in the header (below the site name and above the post), but the font it too large and I don't like the location. I want the Home tab where it is (to the right of the site name), but cannot figure out how to get the tab to actually navigate back to the main site where the posts are http://alltangostl.wordpress.com

  10. Your home page tab in your site links to this: http://alltangostl.wordpress.com/httpwp-mep1jvkj-1e/ which is a page you created called "home."

    Delete that page called home and delete that "home" page from your custom menu since it does not link back to your main blog page.

    After deleting that page from your custom menu, click the "save menu" button.

    Now, go to the pages module and click the "view all" button which will reveal a "home" entry in that module. Check that entry and then add it to your custom menu, place it where you want it by drag and drop and then save your menu again.

    Now when you go to your site main page, or any other page, that "home" tab in your navigation should lead back to your main page.

    The problem was you created a page with the name of "Home" and that is what is causing you the issue.

  11. I thought I almost had it, but still not working. I deleted all the 'homes. I now have a "home" in a custom menu the way you told me to, and it links to the right address. However, I cannot get it where I want it now. This is a link so it keeps showing up in the sidebar, whereas About, Contact, etc are pages at top. How can I add this "home" link to the other pages? This is so confusing and I would think it should be super simple.

  12. Finally got it. I went back into menu, page module, view all, this time I selected ALL options and selected the appropriate menue, and they magically appeared. Now there is a gray area on the tab where I am. I find that sort of unsigtly but I won't complain.

Topic Closed

This topic has been closed to new replies.

About this Topic