Need help? Check out our Support site, then


Cant load my blog

  1. I too have been having problems for about 3 days. 'The connection to the server was reset whilst the page was loading' sometimes I can't access my blog at all. Sometimes I am able to get into it and write a draft post. As soon as I click on save draft I get the error message and I've lost everything I just wrote. SO frustrating... I have tried everything I can from the forums. I haven't done an adobe flash update but I am with talk talk. Could talk talk be the problem? If so, how come it doesn't affect any other sites?

  2. Please Please Please ....someone from WordPress respond to this post....still having huge problems with Blog not loading or stopping working half way through operations....it is very frustrating....I cannot be the only one with issues.....what is being done about this

  3. I have another self hosted blog on WordPress.org, and I have had no problems with that at all, so I am very confused! and very frustrated as I want to use my blog!!!!

  4. I have just checked with my brother who has a WordPress.com blog and he is having the same problems and his ISP is AOL.

  5. I have received a response on another thread to update the setting in the users dashboard to update to https, since I have done that I have not had a problem. Here is the link to show you what to do

    http://en.support.wordpress.com/https/

    Let me know if it works for you too.

  6. It works on self-hosted software, but not on WP hosted software .....

    That tells me a lot.

    I was right.

  7. @ fitchick

    Thanks for that...I've changed it so we will see if that sorts the problem

  8. @: fitchicksoon

    Thanks soooooo much...I changed the dashboard user setting and so far all seems to be back to normal WOOO HOOO

  9. I am also facing the same problem since last week.
    I am not sure if the problem is with wordpress or anything else. It has also affected my blog views for the week

  10. I am also facing the same problem since last week.
    I am not sure if the problem is with wordpress or anything else. It has also affected my blog views for the week

  11. Note what fitchicksoon did above as it resolved her issue. Please try using the https:// log-in http://en.support.wordpress.com/https/

Topic Closed

This topic has been closed to new replies.

About this Topic