Need help? Check out our Support site, then


Can't set featured image using Fresh and Clean theme

  1. I have successfully migrated my blog from blogspot and all posts are visible. I want to set a featured image to each post but can't. I would very much appreciate some help. I have scoured the forums and have tried many suggestions to answer this question for other users but none have been successful. I only have the option of 'insert into post'.The 'set as featured image' option isn't available. I've tried through the 'featured image' option and also through 'add media'. I am using the Fresh and Clean theme and my site address is http://www.elitesportsscience.com
    I downloaded WP in June.

    Thank-you.

    The blog I need help with is elitesportsscience.com.

  2. You have to do this within each post where you want a featured image to show.

    Open the Post Editor and look for the Featured Image module. If you don't see it, click on the "Screen Options" tab at the top right of your screen and make sure the module is enabled.

    Once the module is enabled, you can then click on the link there to set your post's featured image either by uploading it or choosing from the Media Library.

    Read more about using Featured Images on Fresh and Clean's theme showcase page http://theme.wordpress.com/themes/fresh-and-clean/

  3. Hi Jennifer, thank-you very much for responding to my query. I had already attempted to set the featured image in the manner you kindly suggested. I checked the "Screen Options" tab and there wasn't a featured image module to enable. Perhaps this could be my problem? I can't set it through the avenue you suggested. I have checked my image is in the right format and size but no luck. I have spent so long searching for answers! Do you have any other suggestions please?
    Many thanks for your time, Jodi

  4. Odd, when you are on the Post Editor, that Module should be available on Fresh & Clean, and indeed it appears on my test blog using that theme. (screenshot) Featured Image is the 4th one from the left.

    If you still don't see the option to enable it, try logging out of WordPress.com, clearing your browser cache and cookies, shutting down your browser and then open it again.

    Alternately, try a different browser?

  5. Excuse me but just in case please answer this. Are you the Admin of the blog in question?

  6. Good catch, tt.

    Even though I'm a contributor on another site, I can see the Featured Image checkbox in the screen options and can see the module, but if I try to set a featured image I can't because I don't have permission to upload files. Everyone else from Author up to Admin can.

    Since the OP said they migrated their blog from blogspot, I assumed they were Admin.

    And also, for reference, as I seem to have overlooked it earlier:
    http://en.support.wordpress.com/featured-images/#setting-a-featured-image

  7. Hi there tt, fair question; yes I am the administrator. No one else has access to my blog. I managed my blog on blogspot for around 5 years and have just moved to wordpress where I am a complete novice!

    Thank-you justjennifer again for your reply and the links you posted. I have some good news! When I checked the screen options for the 'set featured image' module in the Posts section, I couldn't see it but when I clicked 'new post' and checked the screen options I can see the 'set featured image' module and it is enabled. What I have since realised is that it is my image file that has been the problem. I have been converting a pdf to a jpg and it seems something has gone awry there. Thankfully, I ran a test post with a different image (photo this time) and it was successful! I'm so pleased, now it's just a matter of successfully converting my pdf's into usable images so I'll get stuck into that now! I appreciate you taking the time to help me out. Kind regards, Jodi

  8. Glad you were able to work out the problem. Yep, featured image is just that, an image. /embarrassed grin

    For future reference for anyone else who may encounter a similar problem, accepted filetypes are:
    .jpg
    .jpeg
    .png
    .gif

    And also http://en.support.wordpress.com/images/troubleshooting-images/ especially filenaming and color profiles.

  9. I did know that it should be an image file and had converted my test pdf to a jpg but something must have gone wrong along the way.

    I now have an /embarrassed grin for not checking that first!

    Many thanks to you once again and for the file types above and the troubleshooting link. I got there in the end!

Topic Closed

This topic has been closed to new replies.

About this Topic