Need help? Check out our Support site, then


can't share wordpress posts with facebook even if it's connected

  1. All my posts are selected to share with facebook but it never happens. I only had success twice. What is wrong?

    The blog I need help with is mimosdapatty.com.

  2. Post the snippet and link to your most recent post manually to save time first and then proceed as follows.

    1. Try flushing your FB cache but disconnect from FB first http://umairj.com/146/how-to-clear-facebook-shares-cache/

    2. (a) Try the full reconnect procedure again detailed at http://en.support.wordpress.com/publicize/#reconnecting-facebook including step 3 (removing the FB app), which is probably the most important step.
    (b) http://en.support.wordpress.com/publicize/#reconnecting-twitter

    3. See also publicize troubleshooting http://en.support.wordpress.com/publicize/#troubleshooting

    Note: RSS Grafitti http://www.facebook.com/RSS.Graffiti can be used for posting to Facebook walls if you prefer. RSS Graffiti periodically checks the RSS/Atom feeds that you specify and posts any new entries it finds to the Facebook Walls that you specify. You can get any feed written on any wall (Facebook Profiles, Fan Pages, Groups, Events and Application Profile Pages). In fact, multiple feeds to multiple walls. You choose the combination.

    Please note that reconnecting Publicize with Facebook and/or with Twitter does not re-publicize missed posts, but it will work for future posts.

  3. didn't work

  4. Which step did you get suck on?

  5. I went through all the steps you said.
    Then a made a copy of a post and republished. But still didn't share on facebook.

  6. I'll tag this thread for a Staff follow-up. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  7. Hi there!

    I just tested your connection on the site: pattyrosset.com and found that it was working. I looked at your Facebook profile and saw that your March 27th post was shared:

    https://cloudup.com/czbhqmoe59T

    Did you share that manually? I tested Facebook Publicize using my test account and my Facebook profile and it did work, so I don't think there's a bug. But, please let me know!

    Thanks!

  8. I'm experiencing the same issue. My posts published fine to Facebook and Twitter and LinkedIn, but now my most recent post failed to publish to any of them. The only thing I changed between the successful posts and the new one that didn't get publicized, is that I turned on my domain name for my blog. Would this affect the publicize functions, and if so, shouldn't the domain set-up process warn you that you might have to re-enable the publicize accounts?

  9. @sirhomealot-

    I did see errors in your Publicize connections. Did you change your password? If you change your password you would have to reconnect the connections. I see that you deleted and re-added your connections recently. Please let me know if your next posts don't share.

    Thank you!

  10. Hi gracejiyoung, how long does it typically take for a post to get shared across these networks? I just posted two new articles to my blog and I haven't seen them appear on FB, LinkedIn or Twitter or G+

  11. I'm having almost the same problems as Sirhomealot. It works when it wants. Since the first time I tried to publish my post to facebook, I had wan sucess. But when I publish to Google+ it works. I haven't receive any soluction since my complain.

  12. @pattyrosset, if you look on your previous posts, just over the Publish button it does not show any Publicize connections on your recent posts, so that suggests that for whatever reason, they were not posted on those social networks. I have regenerated your Publicize connection, and it looks like it's in place for your next post.

    @sirhomealot it looks like there were authentication errors connecting your Publicize connections back in April. If you have disconnected and successfully reconnected your blog to your social media networks since then, it should now be working. If not, please try that and see if it helps.

    For both of you, if you still cannot publish posts to your social media sites, please let us know.

  13. Yes, after my previous post, i disconnected an reconnected all of my social networks. It's still not working.

  14. Hi @sirhomealot, I can see that none of the sharing settings are selected on your most recent post, but they seem to be active for a new post. Could you please let me know what happens the next time you publish a post, and if the connections work or not? If they don't, please let me know if you created the new post from the Dashboard Editor or from a different location (http://wordpress.com/post/ , or from a mobile device), and if you published the post immediately or scheduled it to be published.

  15. I'm really confused. When I look at my most recent posts, the sharing dialog box on the right seems to indicate that sharing is turned on, so I don't know why you're not seeing that too. When I post, I do so from the "new post" button at the top of the wordpress.com header which takes me to : http://wordpress.com/post/47012273/new/
    I always publish immediately.

  16. Hmm, it could be that your Publicize options are not working properly when you create a new post from the WordPress.com page. Everything looks correct now, so please let me know if you continue to run into problems with this, and if so, you might try composing a post in your Dashboard editor instead (https://excitabledotca.wordpress.com/wp-admin/post-new.php?post_type=post )to see if that helps, and let me know.

  17. @sirhomealot, I've reported your issue to our developers to see if they can figure out what's going on.

    As a test, could you try disconnecting Google+ from your Publicize connections to see if your next post is sent out to the other social media sites without Google+ in the mix?

  18. OK, finally had something new to post. Did as you asked and disconnected from G+ first. That seems to have worked. The article was successfully shared to LinkedIn, Twitter and FB.
    Only comment: Would be great if the Twitter API could pull in the post's first image too.
    Now, when can I reconnect G+ ??
    :) thanks!!

  19. I'm not sure if you can successfully reconnect Google+ or not. This issue has been reported, but it doesn't appear that they have been able to resolve it yet. You can try reconnecting, but if you run into the same issue, you'll need to disconnect and post your G+ content manually until this has been fixed.

  20. Hi Simon,

    Sorry for the long delay in following up with you. Have you reconnected Google+? Is it working for you properly now? If not, can you try it again now and let us know if it's working?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic