Need help? Check out our Support site, then


Can't turn the new editor off!

  1. Hi guys.

    According to this post http://en.forums.wordpress.com/topic/new-post-editor-improvements?replies=5

    The next time you select to use the classic editor instead of the new editor, we'll remember it! From then on you'll be directed back to the classic view instead, you won't have to select it every time.

    I have select the classic editor MILLIONS OF TIMES, and wordpress still don't remembers my decision. When I try to create a new post from the wordpress top bar on my blog I am redirected to the new editor not the old one. Same goes to editing articles from the front page.

    This is extremely annoying and frustrating.

    Using Firefox 31.0

    The blog I need help with is strangera.com.

  2. This is sadly only saved by browser cookies which means, whenever you delete your cookies or if you have cookies disabled, the software can´t remember that you want to use the old one. This issue has been brought up several times in this thread: http://en.forums.wordpress.com/topic/beep-beep-boop-screen-is-a-joke-is-this-a-glitch?replies=830

    You might want to raise your voice in this thread too.

  3. I haven't disable cookies, and haven't clear them, but still my decision is not saved. So I don't think that this is the problem here.

    Ignoring the fact how retarder is to force such big change without proper testing, I really don't understand why is so hard to add a check box in the settings saying (for example):
    - I want to beta test the new editor;
    - I DON'T WANT TO SEE THE NEW EDITOR EVER AGAIN.

  4. Another day, another "Beep beep boop" message, and still no answer from wordpress?!

  5. This is not the support pages for WordPress, so they are unlikely to respond here.

    However, with respect to your actual problem, after you clicked on the top right to use Classic mode, did you actually create a post? It will only save your preference to use classic mode if you then actually write a post, and not just jump out to test if the setting worked.

    You don't even have to post anything in reality, just type a few characters and save as draft. That is enough to get it to lock in your classic editor preference.

  6. Well, yes it IS the support pages for WP.com.

    I've clicked on Classic mode I don't know how many times from both chrome and Firefox and it never remembers. Never. But clicking on Classic does get you the classic editor. One extra click is worth the effort for the outcome.

  7. Sorry - think I meant that WordPress staff don't necessarily read all the posts and therefore may not respond, not that this isn't where to come to get support!

    (oops)

  8. Agree the extra click is worthwhile. Disappointing that we have to even think of doing so.

  9. @stusshed - yes, I have created a post, but the result is the same. Beep beep boop on the next try to create a new post.

    @raincoaster - true, but it is not only the extra click. It is the fact that I have to wait for about 20 second for the new editor to load, before I can click the "Send me to the old one".

  10. Here is a short video to illustrate my frustration with the new "editor" - http://youtu.be/0n3lFbRDIIc

  11. Dang it. WordPress does not remember my preference for the classic editor.

    BEEP BEEP BOOP.

    I am trying to do a large edit job of a number of my posts, and every BEEP time I have to wait for the new editor to slowly BEEPing load, so I can click on "Classic"

    Not only is it wasting so much extra time, I have tried to do what I need to do in the new editor, and can't. So not only is it a hopeless interface, it is also useless, removing some critical functionality from the classic.

    I've given up editing for the day - my site can stay less than ideal. Is that what you want WordPress - actually discourage people from working on and around their blog? If so, mission accomplished.

  12. @strangera - Nailed it.

    The time for that editor to load.

    The inability for it to remember the preference for classic. (With cookies turned on too)

    The total frustration of having the loud cries not to go down this path being ignored, and even the main post flagging the dissatisfaction being closed because "a major update has been done overnight". I don't see any improvement. And I still have to continually click on "use classic editor"

  13. I can't believe this! They had closed the main tread so they can "suppress" the complains?!

    Dear wordpress, the problems outlined in this tread still exist. Pls provide solution!

  14. This is typical of the way WP.com operates, I'm afraid.

    It also now appears that the new editor fails to send out the posts on RSS and email subscriptions and Publicize. That's going to get a pretty big reaction if it's universal to everyone using the New Editor. Once they figure it out.

  15. @strangera
    I agree - what stunning arrogance to claim the problems are all addressed and solved. They are not and now the picture editor doesn't work properly again either! Incompetence in the extreme.

  16. It´s indeed very stubborn. I don´t see that they want to listen even if there was a massive amount of complains. It´s a sign that they saw our critique as disruptive. To ther issue that storing the classic editor via cookies is not a very good idea since many people delete cookies often, they just say "we have no other plans...". But the fact that many people still have other issues as well, that makes it even more strange that they simply closed the thread. This is not how I would like to communicate with customers.

  17. We value all feedback and are still collecting it of course, though it would be appreciated if you would all post it in your own threads so we can keep track of it and not miss anything. We are also still working through bug reports as we receive them.

    With regards to keeping the new editor off, which is what this particular thread is about (please, no off-topic replies), the preference for new vs. old editor is saved in a browser cookie. If you want to keep that preference, please make sure that you are not clearing your cookies when you close the browser, logging out of WordPress.com, blocking the cookie, or browsing in Private or Incognito mode (which blocks cookies).

  18. Sorry James, I still believe this should be a server-side setting and not a client-side setting. I don't use the same computer/browser combo everywhere and I routinely clear my cookies and cache at the end of every browser session as a security precaution.

    It also now appears that the new editor fails to send out the posts on RSS and email subscriptions and Publicize. That's going to get a pretty big reaction if it's universal to everyone using the New Editor. Once they figure it out.

    @rain-THAT is a deal breaker. If you haven't posted it in its own thread, please, please, please do so.

  19. It cannot be saved in a browser cookie. I have created two posts in a row without even closing the blog tab and the preference has not been saved.

  20. Are you using anything like AdBlock, Ghostery, or Privacy Badger, or browsing in Private or Incognito mode?

  21. I have Adblock on Firefox, but not on Chrome. I'll let you know how the Chrome works later today.

  22. I have created two posts in a row without even closing the blog tab and the preference has not been saved.

    That is exactly what Stranga posted above. His screencast shows it.

  23. Oops. Stranga=Strangera

  24. Fine Blue Death Editor - just finished editing several Posts - each one I had to wait for Blue Death to load - then click on Classic Editor - edit Post - then next Post and wait for Blue Death to load - repeat and repeat

    wasted a lot of time since the Classic Editor selection would not stick - every time on the next Post Blue Death came back

    Firefox current on Win Vista

  25. Ok, I just confirmed that the switch does not work for custom domains. A new bug has been filed (pleading for a standard setting, not a cookie), and I'll now duck behind something to avoid thrown objects.

    At the moment, I highly recommend bookmarking [your-blog]/wp-admin/edit.php as the Edit links and Add New button will open in the classic editor.

    Sorry for the trouble!

  26. pleading for a standard setting, not a cookie

    YAY!

    I'll now duck behind something to avoid thrown objects.

    I have a cream puff handy if you have the coffee... ;-)

    I highly recommend bookmarking [your-blog]/wp-admin/edit.php as the Edit links and Add New button will open in the classic editor

    Done last week!

  27. Hi macmanx, I sad it in the beginning of the tread, but I will write it again in case it is not clear - I have select the classic editor MILLIONS OF TIMES, and wordpress still don't remembers my decision. When I try to create a new post from the wordpress top bar on my blog (front page) I am redirected to the new editor not the old one. Same goes to editing articles from the front page.

    I am not clearing cookies, I am not logging out, I am not blocking the cookies, I am not in Private or Incognito mode. I am not using AdBlock, Ghostery, or Privacy Badger.

    I AM USING Firefox 31.0 and my patience is running lower and lower with every Beep beep boop that I see (and this is happening at least 10 times a day). :)

  28. Yes, sorry for missing that, please see my most recent reply, and thanks to justjennifer for pointing that out.

  29. UPDATE: Oh just saw the new post by macmanx. Great - at least now we know what the problem is. Hope that you pleading gets heard soon, and this horror will end before the end of the month. :)

  30. @James - I was editing existing Posts - would search in Omnishearch for the Post or Page - view the Post - then click on Edit to get the Blue Death Editor - the link you suggested would not work in my case - for new Posts I use the regular editor from the Dashboard which thankfully at this point comes up with the GREAT Classic Editor

Topic Closed

This topic has been closed to new replies.

About this Topic