Need help? Check out our Support site, then


can't view blog, articles, pages

  1. I have 2 blog domains, the main is inamahe.wordpress.com - i can access the admin panel for both accounts, edit articles, change pages, I have full functionality on inamahe, but when I want to view pages, articles or the homepage of the blog, the browser is loading and loading... no page is displayed - neither preview nor "view article" works. with the second blog shipshape8.wordpress.com everything works fine. I did change the start page from article view to static page. but usually this seemed to work fine.

    The blog I need help with is inamahe.wordpress.com.

  2. I just checked and I cannot access the main page on inamahe.wordpress.com either, and http://ismyblogworking.com reports that it got no response from the server for over 15 seconds. I would wait for a few minutes and try again and if it doesn't clear up within say, 30 minutes, contact staff directly at http://en.support.wordpress.com/contact/ .

  3. I can not load http://inamahe.wordpress.com/ with my browser either I recommend you contact staff directly so they look into the matter for you. http://en.support.wordpress.com/contact

  4. Shouldn't there a view front page or view site button on the dashboard? I know there's one someplace, I used it once.

  5. The name of your blog is the link to your home page from your dashboard. as seen in this screen shot http://img64.imageshack.us/img64/6843/screenshot2010.png

  6. Shouldn't there a view front page or view site button on the dashboard? I know there's one someplace, I used it once.

    Exactly my experience. View blog page utton should be available on the dashboard and other mostly used pages of the blog

  7. There is. It's the name of your blog; there used to be a button, but staff changed that so the name of the blog itself is clickable. It's in the top left-hand corner.

  8. Yes, thanks raincoaster I am able to view my blog now. But to avoid frustration to people I would suggest that the view blog button is restored.

Topic Closed

This topic has been closed to new replies.

About this Topic