Need help? Check out our Support site, then


Change name of blog URL

  1. I created an account yesterday and I named my blog URL "expandinghorizons102". I went into settings and tried to change it to "getoutintheworld" and it doesn't seem to have changed.

    The blog I need help with is expandinghorizons102.wordpress.com.

  2. since you have no content in the blog - just register a new blog and use the old one for testing and learning etc (set old blog to private - Dashboard >> Settings >> Reading )

    Dashboard >> My Blogs >> Register a new blog

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.