Need help? Check out our Support site, then


change which API key a blog uses

  1. hi all,

    I have a wordpress installed on a domain, and have a few plugins that need an API key (akismet, wordpress.com stats). I also have two different accounts on wordpress.com.

    up until now, the domain blog has been using the API key from account1, but I am no longer using that account and want it to point to account2. when I attempt to change the API key, I get this error:

    "The owner of that API Key ([account2]) is not on the access list for this blog. When this blog was registered, [account1]'s API key was used. To add you to the access list, [account1] must visit this blog's stats dashboard page and use the form at the bottom of that page."

    ... and yet, I can't get to this mysterious form at the bottom of the blog's stats dashboard page.

    help? how do I do this?

    thank you oh so much.

  2. It's stored within the wp_options table of your blog. Best bet would be to access the database using a tool like phpMyAdmin and delete that record from that table. Do that and the form shoudl reappear.

    You should be asking this over at http://wordpress.org by the way. That's the site for support of the software.


  3. Actually, the form is in the global dashboard:

    http://dashboard.wordpress.com

    Login to the dashboard using the old account and you will see a form on the 'stats' page of your blog at the bottom of the page that has this:

    Stats Access
    Add a User
    
    Type the e-mail address of another WordPress.com user to grant them access to see your blog stats.
    Email address:

    If you don't see it, clear your browser cache and then try again. If that doesn't work, maybe try another browser to see if it comes up. If not, then send a feedback into the staff here at wp.com through your global dashboard, the 'support' tab in this forum or an email to support at wordpress.com

    Trent

  4. thanks trent! I still don't see the form you're referring to, I did try clearing the cache & using IE instead of firefox. I'll send feedback, thanks for the help & advice.

  5. I have the same problem - and I've been around in circles many times. I am hosting my blog on my own domain, I have the API Key, but when I enter it, I get the same as the original poster here - and I too cannot find this mysterious form. When I go to http://dashboard.wordpress.com/ and click on the Dashboard - Blog Stats Page, all I see is:

    No blogs... yet.

    You don’t appear to have any blogs yet, why not start one?

    Thank you for using
    WordPress

    Need help?
    Check out our Frequently Asked Questions.
    Give and receive help in our WordPress.com Forums.
    Read WordPress Documentation.
    Use the feedback link in the upper right corner.

    There is not a form or a link to a form ANYWHERE!!!

    Am I on the wrong page, wrong browser (using FF), what???

Topic Closed

This topic has been closed to new replies.

About this Topic