Need help? Check out our Support site, then


Changed syndication setting but feed not updating

  1. Changed the post count setting {Syndication feeds show the most recent X items} under Reading Settings to 20 but feed still showing larger number of posts.

    Is there a cache which needs to refreshed or another setting i've missed?

    Example: http://uncleweed.wordpress.com/feed/

    Thanks for ideas, for reference i'm reducing the podcast feed filesize to pass along to feedburner.

    The blog I need help with is uncleweed.wordpress.com.

  2. thesacredpath
    Staff

    It may take up to half-hour for the changes to be reflected. Also, clear your browser cache and then look again. It might be an issue with your browser cache. IE is famous for tenaciously hanging onto cached pages (that is how they make it look relatively quick).

  3. thesacredpath
    Staff

    One other thing. You never, ever, ever, ever, ever, ever upload 400k+ images to a website. On my wireless internet connection it took 2 minutes for your main blog page to load. I would simply click away rather than wait, and slow loading web pages are one of the top 10 things people surfing the web hate the most. The other thing is, search engines such as Google now take into account web page loading times when calculating page rank and search engine results page placement, and will penalize slow loading sites. Don't make the gOOg mad. They can kill your blog traffic in a heartbeat by banishing you to page 1,000,757 in the search results.

    Images should never be over 75k in file size, and 50k is even better. Also if you use a lot of images in posts, set your blog to display only 5 posts per page (settings > reading).

    You need to optimize your images and then re-upload them and insert them into the posts replacing the images you are using now.

  4. I think in this case it's the dynamic Flickr widget that's the issue, since it's loading the full-size images. There aren't that many images on the front page, and it loads fast for me (and I'm on a slow computer).

  5. thesacredpath
    Staff

    Rain, I actually pulled three images from the blog posts, and they were all over 400k.

  6. Really? wow. I know Dave personally and it surprises me this would even be an issue. First, my computer is ancient, second Dave is savvy. WTF?

  7. Thanks Sacred and Coaster, ... indeed, I know how to optimize photos and understand deeply the ways of Google ;-)

    This particular wordpress.com site is simply to generate a feed for a podcast to pass to feedburner (to create enclosures and add apple meta data) to then pass to itunes. It isn't made for people to visit to indexed.

    The only problem i am having is: when updating the syndication settings, uncleweed.wordpress.com/feed doesn't reflect the changes. This should occur no matter what content is on the blog.

    Any ideas?

  8. The image sizes can have an effect on the feed as well, since the images are going out on the feed (large images slow down the feed). I'm just suggesting that you keep them smaller in file size. It helps both directly on the blog, and also in the feed. You really don't want a feed set to show 50 posts each with a 400k image in most of them. It just isn't a good thing. I just cleared my cache and went to your feed, and it took just short of 3 minutes for it to load with my wireless internet connection.

    Feeds here sometimes take a while to update, and at other times they update almost instantaneously.

    You can always contact staff directly after they get back on the 19th at http://en.support.wordpress.com/contact/ .

    Please though, optimize your images, no matter what the purpose of this blog is.

  9. passionateaboutbaking
    Member

    May I ask a question here? I have just migrated from Blogger to WP, and my traffic has nosedived. I don't think my feeds are getting delivered and I'm not tech savvy enough to figure out how to check, or what to do. Would appreciate any help. Thank you from a desperate blogger!
    Deeba @ http://www.passionateaboutbaking.com/

  10. Linked site in Post is not a WordPress.COM site: http://ismyblogworking.com/www.passionateaboutbaking.com

    Site linked in name is set to private. Private blogs by definition only get traffic you invite to view, you have shut search engines out.

    Me thinks this is more Spam.

Topic Closed

This topic has been closed to new replies.

About this Topic