Need help? Check out our Support site, then


colors won't change

  1. I can't seem to change the colors on my Forever theme. In the little dots for headings, background, and links they are the colors that I want (bright teal, yellow, and green) but they don't appear that way on the page preview or when I save changes and access it incognito. Why are the colors staying so dark?

    The blog I need help with is flipflopsandfreckles.wordpress.com.

  2. Hey @flipflopsandfreckles,

    do you have the "Custom design" upgrade?
    http://en.support.wordpress.com/custom-design/

    That's the first thing to check. Without the upgrade, the colors you change in the Customize tool won't take effect on the public, live, version of your blog.

    Diego

  3. I rushed my previous reply. I see your blog with the custom colors you mention:

    http://imgur.com/Rs6tT6j

    That looks bright (and right!) from your description.

    Have you tried forcing a refresh (control+shift+r), or clearing your cache?

  4. Hi there, you have this in your custom CSS which is overriding the link color setting you are trying to make in Custom Colors in the Customizer. You need to find the following in your custom CSS and remove it before the yellow links will appear.

    a {
        color: #40E0D0;
    }

    What you enter into the CSS edit window will always override settings make in Custom Colors.

    WordPress.com has algorithms for colors that keep contrast levels at a certain value for visually impaired people, and when you remove the above, you are going to see a darker yellow than what you have chosen since the contrast between your chosen yellow and the white background is not great enough.

    You can see that for yourself by using the above code you have in your CSS now and changing the color value to #FFE135 (your chosen color from Colors).

  5. Thanks guys! I ended up finding a CSS code last night that overrode what was going on with the colors. Is there a way to turn off the auto adjustment so that I don't have to use this override code? It even adjusts the color schemes that are pre-selected.

  6. No, the contrast rules are there to preserve contrast for visually impaired visitors. You can override by using your own CSS rules though.

  7. Aside from the colors, I noticed the site title "flipflopsandfreckles" looks like "HipHopandfreckles" with the FF Market font.

    If you wanted to change just the site title font to be the same as the body text, you could do something like this:

    #masthead #site-title {
        font-family: open-sans-1,open-sans-2,Garamond,"Hoefler Text",Roman,Times,serif;
        font-size: 4em;
    }

    Or if you wanted to keep FF Market but space the letters out a little more so they're easier to read, you could do something like this:

    #site-title {
    	letter-spacing: .1em;
    }

    Or maybe even just switch the heading fonts to another font. I think Futura PT looks really nice with "flipflopsandfreckles."

  8. Awesome tip, thank you. I love the font and adding the space made a big difference.

  9. Glad you are getting things going now. Since you are just starting out, if you do facebook or twitter, or any of the other social networks, you can set up Publicize to automatically share links to your posts on your pages there.

    http://en.support.wordpress.com/publicize/

Topic Closed

This topic has been closed to new replies.

About this Topic