Need help? Check out our Support site, then


Comment form MAJOR FAIL - acts like clicking on a photo

  1. I just inserted a contact form, but when I try to type in the "comment" field, I am taken to a black webpage that shows the image file. This is the same behavior as when I click on the image that appears above the comment form. I tried clicking into any other field (email, etc.) and the same thing happens.

    This is for "strengthaftercancer" and it's hosted on WordPress.

    I can't figure out what is wrong. I'm on OSX and it happens for both Firefox and Chrome.
    Blog url: http://strengthaftercancer.wordpress.com/

  2. Also, I followed the directions on here: http://en.support.wordpress.com/contact-form/

    Did everything as instructed. No idea what's wrong.

  3. Deleted image. Same response

  4. I see a normal page with an image on top and a contact form here > http://strengthaftercancer.com/contact-us/
    I'm using Firefox 15.0.1 and suggest you clear your cache and cookies. http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050
    If your browser need upgrading then you can do that here http://browsehappy.com

  5. There have been strange things here from time to time, but this definitely takes the cake. I've just had the same experience on your contact form while logged out. Putting the cursor in any field sends me to http://strengthaftercancer.files.wordpress.com/2012/07/picture-29.png

    I've tagged this for Staff attention. Hopefully they can get back to us soon.

    Just for informational purposes Chrome 21 on Win7 Pro.

  6. Okay, thank you so much. I am only here for the day, but the site owner - [email redacted] will be available if I am not. She's not super-techie, so please be explicit.

  7. Just a wild guess without having been there since I'm not sure if I can view source code -------

    Maybe an open or misplaced Image Tag?

  8. You're getting this because you've turned the whole contact form into a link to that image. Switch the editor to Text (=code); you should see this:
    <a href="http://strengthaftercancer.files.wordpress.com/2012/07/picture-29.png">[contact-form]</a>
    Delete all this except this part:
    [contact-form]

  9. Ya' know, I probably meant to say image and/or link tag.

    Oh well.

  10. YES!!!!!!!!!!!! FIXED!
    I don't know how that happened because I was using the wysiwyg editor - I actually thought that I didn't have code access bc this a WP.com site and there's not "editor" option, but apparently the "text" tab in the page edit panel is the same as the "html" view in my own site.

    THANK YOU ALL OMG

  11. You're welcome.
    Yes, 'Text" is the new name WP gave to the former "HTML" tab. Both are misnomers.

  12. How odd that the contact form was inserted in the middle of other code. Glad that notawoodpecker and justpi could help you out.

  13. Jenn, I've seen the same thing happen on eBay listings. A misplaced tag can create all sorts of havoc. I've seen entire auction pages become links effectively disabling many of the other links that were supposed to work.

    We used to find all kinds of things when I was cruising the eBay boards; some of which baffled us trying to find that one odd bit of code. I went blind a few times back then.

    I'm just not familiar enough yet with WP code and what is or isn't supposed to be where, so I didn't dig into this one too deeply.

Topic Closed

This topic has been closed to new replies.

About this Topic