Need help? Check out our Support site, then


Commenters avatars don't show up (except WP accounts)

  1. I have the Settings > Discussion options set so avatars appear with comments but only those who comment using a WP account will have an avatar. I have it set to display the generic one when people don't have avatars but it displays for everyone, regardless. For example, someone commenting with a Blogger account should definitely have an avatar but it doesn't show up. I've tried switching it to the gravatar option but with that set it only shows the default Gravatar logo. Please help!

    The blog I need help with is paperandpretties.wordpress.com.

  2. For example, someone commenting with a Blogger account should definitely have an avatar but it doesn't show up.

    Incorrect. Google owns Blogger and the avatars they use are not globally recognized Gravatars. Automattic owns both WordPress.com and Gavatar and every WordPress.com account is a Gravatar account so the Gravatars will display. http://gravatar.com/ Blogger avatars will not display on your blog.

Topic Closed

This topic has been closed to new replies.

About this Topic