Need help? Check out our Support site, then


Commenting errors

  1. Hi! I recently learned that quite a few of my readers who do not have a WP account are having problems commenting on my blog (https://siljethereses.wordpress.com/) . I checked my settings, and I haven't ticked the "Users must be registered and logged in to comment ". I only require name + e-mail.
    Any ideas what it could be or what I can do to fix it? I find it rather annoying when my readers cannot comment on my posts. They're told that they have to have an WP account in order to being able to comment :/

    The blog I need help with is siljethereses.wordpress.com.

  2. "You are being asked to login because [email redacted] is used by an account you are not logged into now"

  3. This page > Settings > Discussion is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    Discussion Settings
    Other comment settings
    _Comment author must fill out name and e-mail
    _Users must be registered and logged in to comment

    Note that the prompt to submit and email address and a website URL will still appear, but providing an email address and logging in are not required, and you cannot change this so the prompt does not appear.

    You can post instructions for your visitors in a text widget if you wish to set up anonymous commenting. That's easy to do. You copy and paste this into a text widget:

    Readers: Note that the email address and logging in prompts do appear for comments on this blog, but providing an email address and logging in are not required.

    P.S. Do be sure to set up full comment moderation ie. "An administrator must always approve the comment" because anonymous commenting is bound to increase the amount of spam your blog will receive.
    http://en.support.wordpress.com/settings/discussion-settings/#comment-moderation

Topic Closed

This topic has been closed to new replies.

About this Topic